libgtk2.0-dev无法安装

软件源讨论区
回复
if
帖子: 62
注册时间: 2006-09-12 1:25
送出感谢: 0
接收感谢: 0

libgtk2.0-dev无法安装

#1

帖子 if » 2006-11-19 17:50

出错信息如下

代码: 全选

gongwei@gongwei-laptop:~$ sudo apt-get install libgtk2.0-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  libgtk2.0-dev: 依赖: libxcursor-dev 但是它将不会被安装
                 依赖: libxfixes-dev 但是它将不会被安装
E: 无法安装的软件包
gongwei@gongwei-laptop:~$ sudo apt-get install libxfixes-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  libxfixes-dev: 依赖: libxfixes3 (= 1:3.0.1.2-0ubuntu3) 但是 1:4.0-0ubuntu1 正要被安装
E: 无法安装的软件包
gongwei@gongwei-laptop:~$
貌似源里面有问题阿,我用cn99,sjtu,ustc,tisnghua的源,hiweed
请管理员更正依赖关系
回复

回到 “新立得和软件源”