当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 不能安装PPA了
帖子发表于 : 2012-01-06 20:54 
头像

注册: 2009-05-09 14:58
帖子: 297
地址: 江苏
送出感谢: 0 次
接收感谢: 0 次
代码:
~$ sudo apt-add-repository ppa:fcitx-team/nightly

产生一下错误:
代码:
You are about to add the following PPA to your system:
 Fcitx Nightly PPA
 Experimental releases of Fcitx, use with caution.
 More info: https://launchpad.net/~fcitx-team/+archive/nightly
Press [ENTER] to continue or ctrl-c to cancel adding it

Traceback (most recent call last):
  File "/usr/bin/apt-add-repository", line 99, in <module>
    sp = SoftwareProperties(options=options)
  File "/usr/lib/python2.7/dist-packages/softwareproperties/SoftwareProperties.py", line 96, in __init__
    self.reload_sourceslist()
  File "/usr/lib/python2.7/dist-packages/softwareproperties/SoftwareProperties.py", line 580, in reload_sourceslist
    self.distro.get_sources(self.sourceslist)   
  File "/usr/lib/python2.7/dist-packages/aptsources/distro.py", line 91, in get_sources
    raise NoDistroTemplateException("Error: could not find a "
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template

肿么办啊,各位大神?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 不能安装PPA了
帖子发表于 : 2012-01-06 21:21 
头像

注册: 2009-12-12 19:29
帖子: 5070
地址: 随便一个地方
系统: 本地大型发行版除外
送出感谢: 0 次
接收感谢: 166
有没有装深度软件中心?


_________________
Github见!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 不能安装PPA了
帖子发表于 : 2012-01-06 21:35 
头像

注册: 2010-05-23 20:44
帖子: 1665
系统: Ubuntu
送出感谢: 8
接收感谢: 22
居然是深度软件中心搞得鬼?还是别的原因?


_________________
师大生信者:http://bnuzhutao.cn


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 不能安装PPA了
帖子发表于 : 2012-01-06 21:37 
头像

注册: 2009-05-09 14:58
帖子: 297
地址: 江苏
送出感谢: 0 次
接收感谢: 0 次
mraandtux 写道:
有没有装深度软件中心?

安装了,我的grub也被改成Linux deepin了,难道真的是这个问题,卸载深度可以解决吗?


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 不能安装PPA了
帖子发表于 : 2012-01-06 22:13 
头像

注册: 2009-05-09 14:58
帖子: 297
地址: 江苏
送出感谢: 0 次
接收感谢: 0 次
按hyhai7 的方法修改成功
修正/etc/lsb-release文件内的信息和你版本信息一致即可,例如Ubuntu 11.10的信息如下(可直接复制):

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu 11.10"

深度软件中心卸载了 :em05


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 不能安装PPA了
帖子发表于 : 2012-03-10 15:12 

注册: 2008-09-06 13:05
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
我没有安装深度软件中心,怎么也被改成LinuxDeepin了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译