当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : libc6-dev被损坏且无法修复
帖子发表于 : 2012-03-26 19:57 
头像

注册: 2011-01-17 22:23
帖子: 191
送出感谢: 0 次
接收感谢: 1
RT.....我用的是ubuntu10.04, 因某些原因想重装libc6-dev,然后到网上下载了一个libc6的deb包,不过没想到这个包比系统中现有的libc6-dev的版本要低,结果安装过程中就出现错误,然后用
代码:
sudo apt-get -f install
之后也无法修复,
代码:
apt-get -f install
几乎要卸掉我的整个桌面........
代码:
您也许需要运行“apt-get -f install”来修正上面的错误。
下列软件包有未满足的依赖关系:
  libc-dev-bin: 依赖: libc6 (> 2.13~) 但是 2.11.3-2 已经安装
                推荐: manpages-dev 但是它还没有被安装
  libc6: 依赖: libc-bin (= 2.11.3-2) 但是 2.13-0ubuntu13.1 已经安装
         推荐: libc6-i686 但是它还没有被安装
  libc6-amd64: 依赖: libc6 (= 2.13-0ubuntu13.1) 但是 2.11.3-2 已经安装
  libc6-dev: 依赖: libc6 (= 2.13-0ubuntu13.1) 但是 2.11.3-2 已经安装
  libnih1: 依赖: libc6 (> 2.13~) 但是 2.11.3-2 已经安装
  multiarch-support: 依赖: libc6 (>= 2.13-0ubuntu6) 但是 2.11.3-2 已经安装
  ubuntu-minimal: 依赖: libc6-i686 但是它还没有被安装
E: 不能满足依赖关系。不妨试一下 -f 选项。


_________________
苏东坡问佛印道:“人人皆念观世音菩萨,观世音菩萨念谁?”
佛印答道:“念观世音菩萨。”
苏东坡诧异:“为何亦念观世音菩萨?”
曰:“求人不如求己。”


页首
 用户资料  
 
2 楼 
 文章标题 : Re: libc6-dev被损坏且无法修复
帖子发表于 : 2012-03-26 20:50 

注册: 2007-01-14 16:23
帖子: 4347
送出感谢: 0 次
接收感谢: 109
这个……这样应该是开发库……应该没那么严重……先把开发库卸掉看看……如果真的要卸掉桌面……那就卸载吧,总比卸载系统强……


_________________
#include <stdio.h>
void main()
{
double world;
unsigned letter;
short stay;
long memories;
printf("I miss you.\n");
}


页首
 用户资料  
 
3 楼 
 文章标题 : Re: libc6-dev被损坏且无法修复
帖子发表于 : 2012-03-26 23:42 
头像

注册: 2011-01-17 22:23
帖子: 191
送出感谢: 0 次
接收感谢: 1
onlylove 写道:
这个……这样应该是开发库……应该没那么严重……先把开发库卸掉看看……如果真的要卸掉桌面……那就卸载吧,总比卸载系统强……

:em45 :em48 干脆等12.04正式版来了,我直接重装个12.04算了


_________________
苏东坡问佛印道:“人人皆念观世音菩萨,观世音菩萨念谁?”
佛印答道:“念观世音菩萨。”
苏东坡诧异:“为何亦念观世音菩萨?”
曰:“求人不如求己。”


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译