apt-get 为什么会连接ipv6的地址更新软件包?

软件源讨论区
回复
头像
langyxxl
帖子: 443
注册时间: 2012-01-17 22:17
送出感谢: 3 次
接收感谢: 20 次

apt-get 为什么会连接ipv6的地址更新软件包?

#1

帖子 langyxxl » 2015-12-09 16:26

我在公司的服务器上运行apt-get upgrade报如下错误,我没有ipv6的地址:
Failed to fetch http://security.ubuntu.com/ubuntu/dists ... elease.gpg Cannot initiate the connection to security.ubuntu.com:80 (2001:67c:1562::15). - connect (101: Network is unreachable) [IP: 2001:67c:1562::15 80]

关键是我再次执行命令,又成功执行,然后我建了一台虚拟机,不停进行apt-get upgrade,基本5次中会有一次去连接这个ipv6地址。。 :Angry

但是我nslookup查找security.ubuntu.com的IP,每次都返回的是ipv4的地址

有人也遇到这个情况吗,有点郁闷,这种概率问题好难调查。
poloshiao
论坛版主
帖子: 18001
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1914 次

Re: apt-get 为什么会连接ipv6的地址更新软件包?

#2

帖子 poloshiao » 2015-12-09 16:35

基本5次中会有一次去连接这个ipv6地址。。
1. 參考
viewtopic.php?f=180&t=472490
我没有ipv6的地址:
2. 可以考慮把 Ubuntu 的 IPv6 關閉 等有需要用到 IPv6 時再 打開
http://askubuntu.com/questions/440649/h ... untu-14-04
How to disable IPv6 in Ubuntu 14.04?
头像
vickycq
论坛版主
帖子: 4552
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: apt-get 为什么会连接ipv6的地址更新软件包?

#3

帖子 vickycq » 2015-12-09 16:51

由于运营商的设置导致试图使用 ipv6
临时强制 apt-get 使用 ipv4:

代码: 全选

apt-get -o Acquire::ForceIPv4=true update
永久生效
创建文件 /etc/apt/apt.conf.d/99force-ipv4 加入:

代码: 全选

Acquire::ForceIPv4 "true";
参考
https://www.vultr.com/docs/force-apt-ge ... -or-debian
http://unix.stackexchange.com/questions ... pv6-method
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
回复

回到 “新立得和软件源”