我应该如何保存依赖关系列表

软件源讨论区
回复
yubinalice
帖子: 112
注册时间: 2015-12-23 16:20
系统: ubuntu 16.04
送出感谢: 1 次
接收感谢: 0

我应该如何保存依赖关系列表

#1

帖子 yubinalice » 2015-12-23 16:24

如题,
目前我遇到这么一个问题,
比如我想要编译一个mpv-player以及一个xbmc软件,再ubuntu 15里面可以如此处理,
apt-get build-dep mpv xbmc,就可以了,
但是在ubuntu里面,如此操作就会返回错误。
所以我想要再ubuntu15里面利用apt-get弄出一个依赖关系表。
然后放到ubuntu 16里面进行安装,就是不再利用build-dep安装,而是利用apt-get install来完成。
所以i我应该如何生成这个依赖列表?
谢谢!!!
头像
vickycq
论坛版主
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 995 次
联系:

Re: 我应该如何保存依赖关系列表

#2

帖子 vickycq » 2015-12-23 17:08

但是在ubuntu里面,如此操作就会返回错误。
把完整的错误信息贴上来
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
yubinalice
帖子: 112
注册时间: 2015-12-23 16:20
系统: ubuntu 16.04
送出感谢: 1 次
接收感谢: 0

Re: 我应该如何保存依赖关系列表

#3

帖子 yubinalice » 2015-12-29 22:52

错误信息?
没有什么错误信息。
大概就是所有的包都已经安装完了,不需要安装了。
如果是第一次安装,
会出现一大堆的列表,然后又需要占用的空间什么的提示。
如果已经安装过,就不会出现需要的列表。
谢谢!!!
头像
AutoXBC
帖子: 1744
注册时间: 2007-10-23 12:54
送出感谢: 2 次
接收感谢: 24 次

Re: 我应该如何保存依赖关系列表

#4

帖子 AutoXBC » 2015-12-30 3:08

先在 http://packages.ubuntu.com 网站搜索 mpv,可以进入这个页面 http://packages.ubuntu.com/xenial/mpv ,在页面右侧有个 下载源码包 [mpv_0.14.0-1.dsc],打开这个链接可以得到编译配置文件,其中的 Build-Depends 字段就是编译依赖,也是 build-dep 这个命令工作时读取的配置。

像上面说的,还是应该重点解决 build-dep 的错误,没有任何提示有可能本身就没出错,编译时的错误并不一定是编译依赖没处理好。
回复

回到 “新立得和软件源”