低版本的Ubuntu可以使用高版本的apt源吗?

软件源讨论区
回复
张小嫱
帖子: 13
注册时间: 2016-12-17 10:20
系统: Ubuntu
送出感谢: 3 次
接收感谢: 0

低版本的Ubuntu可以使用高版本的apt源吗?

#1

帖子 张小嫱 » 2016-12-18 11:29

小菜鸟又来求助了! :Adore
因实验需要,要装Ubuntu12.04,然而实验室的电脑不能联网,实验室只有Ubuntu16.04的apt镜像源。
那么问题来了,低版本的Ubuntu可以使用高版本的apt源吗?
我试着修改了etc/apt/sources.list的配置文件,然而更新失败,不知道是不是上述的原因呢?
对于我这种情况和需求,有什么简便的安装软件的解决方法吗?先谢谢大家啦~
头像
vickycq
论坛版主
帖子: 4552
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: 低版本的Ubuntu可以使用高版本的apt源吗?

#2

帖子 vickycq » 2016-12-18 11:52

张小嫱 写了:那么问题来了,低版本的Ubuntu可以使用高版本的apt源吗
绝大多数情况下不可以,会造成严重问题。建议立即换回来
张小嫱 写了:因实验需要,要装Ubuntu12.04
实验室只有Ubuntu16.04的apt镜像源
有什么简便的安装软件的解决方法吗?
1. 是否一定要使用 12.04
3. 需视具体情况而定,可进一步说明具体需求。比如为何一定要使用 12.04,无法联网是技术问题还是政策问题。
上次由 vickycq 在 2016-12-18 12:41,总共编辑 1 次。
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
头像
b33e
论坛版主
帖子: 3866
注册时间: 2011-06-07 14:20
系统: Mint18
送出感谢: 16 次
接收感谢: 62 次

Re: 低版本的Ubuntu可以使用高版本的apt源吗?

#3

帖子 b33e » 2016-12-18 12:36

不能。
先看看需求是否一定要12.04版本吧。
poloshiao
论坛版主
帖子: 18194
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1925 次

Re: 低版本的Ubuntu可以使用高版本的apt源吗?

#4

帖子 poloshiao » 2016-12-18 13:52

实验室的电脑不能联网
到可以上網的電腦 下載 12.04.5-dvd-amd64.iso
http://cdimage.ubuntu.com/releases/12.04.5/release/
燒錄成 Live USB
帶著 Live USB 到实验室的电脑 開機 登入試用桌面 試用一段時間看看

補充
ubuntu-12.04.5-dvd-amd64.iso 1.7G

http://releases.ubuntu.com/releases/12.04.5/
ubuntu-12.04.5-desktop-amd64.iso 758M
包含更多 main / restricted 套件源的套件
张小嫱
帖子: 13
注册时间: 2016-12-17 10:20
系统: Ubuntu
送出感谢: 3 次
接收感谢: 0

Re: 低版本的Ubuntu可以使用高版本的apt源吗?

#5

帖子 张小嫱 » 2016-12-18 14:59

张小嫱 写了:因实验需要,要装Ubuntu12.04
实验室只有Ubuntu16.04的apt镜像源
有什么简便的安装软件的解决方法吗?
1. 是否一定要使用 12.04
3. 需视具体情况而定,可进一步说明具体需求。比如为何一定要使用 12.04,无法联网是技术问题还是政策问题。[/quote]

实验室规定不能联网 :Noting
我的具体需求是:
比较几个大版本的内核对程序功耗的影响,包括2.6,3.几,和4.几。现在就有些尴尬了:
1. 尝试借助现有的16.04源,在Ubuntu16.04下编译内核2.6,结果因为systemd启动只支持大于等于3的内核,此方法失败。
2.安装Ubuntu12.04(内核3.13),再编译2.6和4.4,但却没有现成的源可用
3.安装Ubuntu10.04(内核2.6),再编译3.几和4.4,也没有现成的源可用。

从编译的角度以及软件获取的角度,您觉得哪种方法更可取呢?谢谢帮助!
张小嫱
帖子: 13
注册时间: 2016-12-17 10:20
系统: Ubuntu
送出感谢: 3 次
接收感谢: 0

Re: 低版本的Ubuntu可以使用高版本的apt源吗?

#6

帖子 张小嫱 » 2016-12-18 15:06

poloshiao 写了:
实验室的电脑不能联网
到可以上網的電腦 下載 12.04.5-dvd-amd64.iso
http://cdimage.ubuntu.com/releases/12.04.5/release/
燒錄成 Live USB
帶著 Live USB 到实验室的电脑 開機 登入試用桌面 試用一段時間看看

補充
ubuntu-12.04.5-dvd-amd64.iso 1.7G

http://releases.ubuntu.com/releases/12.04.5/
ubuntu-12.04.5-desktop-amd64.iso 758M
包含更多 main / restricted 套件源的套件
谢谢你的回答!小菜鸟想再追问一下,我现在装的是Ubuntu12.04的server版,所以您的建议是直接使用USB中的Ubuntu系统?还是借用USB里的套件来安装一些软件?
poloshiao
论坛版主
帖子: 18194
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1925 次

Re: 低版本的Ubuntu可以使用高版本的apt源吗?

#7

帖子 poloshiao » 2016-12-18 17:25

我现在装的是Ubuntu12.04的server版,所以您的建议是直接使用USB中的Ubuntu系统?
1. ISO 燒錄的是 desktop 版
2. desktop 版 = server 版 + 桌面系統
2-1. desktop 桌面 按下 ctrl + alt + F1 登入 tty1
就是登入 server 版
2-2. 再按下 ctrl + alt + F7 出現 tty7
就是 桌面系統
2-3. 也可以把 tty7 關閉
sudo stop lightdm
2-3-1. 這個時候 如果要再啟動 tty7
sudo start lightdm

3. 試用桌面 其實也是一種安裝
只是 開機過程 把 RAM 模擬成虛擬磁盤
並且把 Ubuntu 安裝在 虛擬磁盤
使用上 跟 把 ubuntu 安裝在實體硬盤 並無太大差別
3-1. 如果 RAM 太小 可能會影響效能
如果 RAM 夠大 效能比 安裝在實體硬盤 還好
3-2. 差別 只是 關機以後
RAM 模擬成的虛擬磁盤 歸零
設定檔 如果要能夠保存 需要在 燒錄 Live USB 時 多一個 "persistence" 的選項
否則 每次開機登入試用桌面 都需要重新設定一次
还是借用USB里的套件来安装一些软件?
4. 試用桌面的 套件來源表 /etc/apt/sources.list 完全一樣
4-1. 要分清楚 是安裝在 虛擬磁盤 還是安裝在 實體硬盤 見 3-2

5. 在 Ubuntu (或說 Linux)
套件及套件版本的相依關係 是系統能否穩定執行的關鍵
12.04 及 16.04 套件套件版本的相依關係 差異很大
建議 不要想混搭執行
5-1. 最好把
RAM 模擬成的虛擬磁盤安裝的試用桌面

實體硬盤安裝的桌面
完全分割清楚
不要混用
5-2. 檔案 則都可以儲存在實體硬盤

6. Ubuntu 軟體來源套件庫 分為 main, restricted, universe 及 multiverse 四種
ISO 中的套件 主要來自 main, restricted 部份套件 (不是 全部)
ubuntu-12.04.5-desktop-amd64.iso 758M 少一些
ubuntu-12.04.5-dvd-amd64.iso 1.7G 多一些
6-1. 其它的套件 可以尋同樣的方法
找可以上網的電腦 下載 deb 檔案 存進 U 盤
再把 U 盤插進 实验室的电脑
sudo dpkg -i /path/*.deb
就可以安裝
但是 套件相依的問題 需要自行解決
6-2. 還有其它解決方案 你真正碰到時 再貼文討論
这些用户感谢了作者 poloshiao 于这个帖子:
张小嫱 (2016-12-18 21:10)
评价: 3.7%
头像
vickycq
论坛版主
帖子: 4552
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: 低版本的Ubuntu可以使用高版本的apt源吗?

#8

帖子 vickycq » 2016-12-18 17:52

张小嫱 写了:结果因为systemd启动只支持大于等于3的内核
此条信息的来源?确保编译内核时开启以下选项
CONFIG_DEVTMPFS=y
CONFIG_CGROUPS=y
CONFIG_AUTOFS4_FS=y
CONFIG_IPV6=y
CONFIG_FANOTIFY=y
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
张小嫱
帖子: 13
注册时间: 2016-12-17 10:20
系统: Ubuntu
送出感谢: 3 次
接收感谢: 0

Re: 低版本的Ubuntu可以使用高版本的apt源吗?

#9

帖子 张小嫱 » 2016-12-18 21:09

vickycq 写了:
张小嫱 写了:结果因为systemd启动只支持大于等于3的内核
此条信息的来源?确保编译内核时开启以下选项
CONFIG_DEVTMPFS=y
CONFIG_CGROUPS=y
CONFIG_AUTOFS4_FS=y
CONFIG_IPV6=y
CONFIG_FANOTIFY=y
信息是从https://wiki.gentoo.org/wiki/Systemd/zh-cn上看到的
截图在附件。所以是否可以放弃在16.04上编译2.6的内核了?
附件
屏幕快照 2016-12-18 下午9.07.41.png
头像
vickycq
论坛版主
帖子: 4552
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: 低版本的Ubuntu可以使用高版本的apt源吗?

#10

帖子 vickycq » 2016-12-18 21:35

张小嫱 写了:信息是从https://wiki.gentoo.org/wiki/Systemd/zh-cn上看到的
页面译成中文时漏了“等于”二字。即内核版本应大于等于 2.6.39
wiki.gentoo.org/wiki/Systemd 写了:Right now, the lower bound on kernel version is set in the ebuild to 2.6.39.
wiki.debian.org/systemd 写了:If you run a self-compiled kernel, make sure you have 2.6.39 or newer
这些用户感谢了作者 vickycq 于这个帖子:
张小嫱 (2016-12-18 22:31)
评价: 3.7%
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
张小嫱
帖子: 13
注册时间: 2016-12-17 10:20
系统: Ubuntu
送出感谢: 3 次
接收感谢: 0

Re: 低版本的Ubuntu可以使用高版本的apt源吗?

#11

帖子 张小嫱 » 2016-12-18 22:30

vickycq 写了:
张小嫱 写了:信息是从https://wiki.gentoo.org/wiki/Systemd/zh-cn上看到的
页面译成中文时漏了“等于”二字。即内核版本应大于等于 2.6.39
wiki.gentoo.org/wiki/Systemd 写了:Right now, the lower bound on kernel version is set in the ebuild to 2.6.39.
wiki.debian.org/systemd 写了:If you run a self-compiled kernel, make sure you have 2.6.39 or newer
这样子啊···看来我查阅资料还不够细致··· :Noting
可是我有在Ubuntu16.04下编译过2.6.39内核,结果出现了以下错误,我之前还发了另一个求助帖
viewtopic.php?f=186&t=482056
我还以为是systemd不支持的原因。如果2.6.39内核支持systemd的话,您觉得出现这种错误是什么原因呢?谢谢您一直耐心的解答!
附件
屏幕快照 2016-12-17 上午10.46.13.png
头像
vickycq
论坛版主
帖子: 4552
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: 低版本的Ubuntu可以使用高版本的apt源吗?

#12

帖子 vickycq » 2016-12-19 10:29

为少折腾故,您可以考虑将 16.04 切换回 upstart,抛弃 systemd
或使用 debian 一类在 cd/dvd 镜像中提供较完整离线软件源的发行版。

参考
https://wiki.ubuntu.com/SystemdForUpsta ... it_systems
http://notesofaprogrammer.blogspot.com/ ... 4-lts.html
http://askubuntu.com/questions/760615/u ... -installed
这些用户感谢了作者 vickycq 于这个帖子:
张小嫱 (2016-12-19 20:54)
评价: 3.7%
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
张小嫱
帖子: 13
注册时间: 2016-12-17 10:20
系统: Ubuntu
送出感谢: 3 次
接收感谢: 0

Re: 低版本的Ubuntu可以使用高版本的apt源吗?

#13

帖子 张小嫱 » 2016-12-19 21:09

vickycq 写了:为少折腾故,您可以考虑将 16.04 切换回 upstart,抛弃 systemd
或使用 debian 一类在 cd/dvd 镜像中提供较完整离线软件源的发行版。

参考
https://wiki.ubuntu.com/SystemdForUpsta ... it_systems
http://notesofaprogrammer.blogspot.com/ ... 4-lts.html
http://askubuntu.com/questions/760615/u ... -installed
好的!可是既然systemd是支持2.6.39的,将16.04切换回upstart,就能保证编译通过了吗?应该对症下药,不知道systemd是不是那个“症”呢?
我还是去尝试一下,谢谢您~ :Grimace
poloshiao
论坛版主
帖子: 18194
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1925 次

Re: 低版本的Ubuntu可以使用高版本的apt源吗?

#14

帖子 poloshiao » 2016-12-20 12:01

不知道systemd是不是那个“症”呢?
如果是 systemd
systemd 作者 Lennart Poettering
在這一篇
提供一個技巧
可以讓你印出 出問題的源碼

http://0pointer.net/blog/projects/journal-submit.html
systemd for Developers III
使用 sd_journal_print 關鍵字 搜尋

看看 能否幫你找出問題之所在
回复

回到 “新立得和软件源”