当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : apt-get install 软件失败,缺少依赖项
帖子发表于 : 2017-04-13 10:29 

注册: 2016-12-12 14:30
帖子: 15
系统: ubuntu 14.04
送出感谢: 2
接收感谢: 0 次
安装openssh-server报下面的错误。其他软件也安装失败,网上说换源什么的,试了 163 sohu hust等都无效,有大侠知道别的原因导致安装软件失败吗?
我的系统是 : 14.04.5 64位

代码:
ubuntu@ubuntu-dou:~$ sudo apt-get install openssh-server
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 libcogl15 : 依赖: libegl1-mesa-drivers
 libsdl2-2.0-0 : 依赖: libwayland-egl1-mesa (>= 10.0.2) 或
                         libwayland-egl1
 openssh-server : 依赖: openssh-client (= 1:6.6p1-2ubuntu1)
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: apt-get install 软件失败,缺少依赖项
帖子发表于 : 2017-04-13 10:51 

注册: 2016-12-12 14:30
帖子: 15
系统: ubuntu 14.04
送出感谢: 2
接收感谢: 0 次
解决了。
原因是:我现在已经安装的版本较高,新需要安装的版本较低。
解决办法:安装指定的版本
具体操作见:https://my.oschina.net/lhplj/blog/336313


页首
 用户资料  
 
3 楼 
 文章标题 : Re: apt-get install 软件失败,缺少依赖项
帖子发表于 : 2017-04-13 13:46 

注册: 2016-12-12 14:30
帖子: 15
系统: ubuntu 14.04
送出感谢: 2
接收感谢: 0 次
最根本的原因是我把 【系统设置】->【软件和更新】->【更新】中,取消勾选 【重要安全更新】和【推荐更新】
把这两个勾选上,再update一下就可以用了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译