ubuntu软件无法更新

软件源讨论区
回复
centos2009
帖子: 4
注册时间: 2009-05-28 23:43
送出感谢: 0
接收感谢: 0

ubuntu软件无法更新

#1

帖子 centos2009 » 2018-03-25 19:50

使用apt-get安装任何软件都出现下面错误

Welcome to Alibaba Cloud Elastic Compute Service !

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
checkbox-converged : Depends: qtdeclarative5-ubuntu-ui-toolkit-plugin but it is not installable
evince : Depends: libevdocument3-4 (= 3.26.0-2) but 3.18.2-1ubuntu4.3 is to be installed
gvfs-backends : Depends: libgdata22 (>= 0.17.9) but 0.17.4-1 is to be installed
hplip : Depends: hplip-data (= 3.17.10+repack0-2) but 3.16.3+repack0-1 is to be installed
Depends: printer-driver-hpcups (= 3.17.10+repack0-2) but 3.16.3+repack0-1 is to be installed
Depends: libsane1 (>= 1.0.24) but it is not going to be installed
initramfs-tools-core : Depends: initramfs-tools-bin (= 0.125ubuntu13) but 0.122ubuntu8.10 is to be installed
klibc-utils : Depends: libklibc (= 2.0.4-9ubuntu2) but 2.0.4-8ubuntu1.16.04.4 is to be installed
liboxideqtquick0 : Depends: liboxideqtcore0 (= 1.21.5-0ubuntu0.16.04.1) but it is not installable
libreoffice-calc : Depends: liborcus-0.12-0 but it is not installable
libreoffice-core : Depends: libclucene-contribs1v5 (>= 2.3.3.4+dfsg) but 2.3.3.4-4.1 is to be installed
Depends: libclucene-core1v5 (>= 2.3.3.4+dfsg) but 2.3.3.4-4.1 is to be installed
Depends: libcmis-0.5-5v5 (>= 0.5.1+git20160603) but 0.5.1-2ubuntu2 is to be installed
Depends: libgpgmepp6 (>= 1.8.0) but it is not going to be installed
Depends: liborcus-0.12-0 but it is not installable
Depends: libpoppler68 (>= 0.57.0) but it is not installable
Depends: libxmlsec1 (>= 1.2.25) but it is not going to be installed
Depends: libxmlsec1-nss (>= 1.2.25) but it is not going to be installed
libreoffice-gnome : Depends: libreoffice-gtk3 but it is not going to be installed
libreoffice-gtk : Depends: libreoffice-gtk2 but it is not going to be installed
libreoffice-writer : Depends: libabw-0.1-1 but it is not going to be installed
onboard : Depends: onboard-common (< 1.4.1-2ubuntu1.1) but it is not going to be installed
Depends: onboard-common (>= 1.4.1-2ubuntu1) but it is not going to be installed
Recommends: onboard-data (>= 1.4.1-2ubuntu1) but 1.2.0-0ubuntu5 is to be installed
python3-cryptography : Depends: python3-asn1crypto but it is not going to be installed
python3-pil : Depends: python3-olefile but it is not going to be installed
Depends: libwebpmux3 (>= 0.6.0-4) but it is not going to be installed
totem : Depends: libtotem0 (>= 3.26.0-0ubuntu2) but 3.18.1-1ubuntu4 is to be installed
Depends: grilo-plugins-0.3-base but it is not going to be installed
totem-plugins : Depends: libtotem0 (>= 3.26.0-0ubuntu2) but 3.18.1-1ubuntu4 is to be installed
Depends: gir1.2-totem-1.0 (= 3.26.0-0ubuntu2) but 3.18.1-1ubuntu4 is to be installed
unity-webapps-qml : Depends: liboxideqt-qmlplugin (>= 1.3.0) but it is not installable or
qml-module-qtwebkit but it is not going to be installed
Depends: qtdeclarative5-ubuntu-ui-toolkit-plugin but it is not installable or
qtdeclarative5-ubuntu-ui-toolkit-plugin-gles but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution)


使用apt-get -f install更新提示
poloshiao
论坛版主
帖子: 18244
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: ubuntu软件无法更新

#2

帖子 poloshiao » 2018-03-25 20:27

Welcome to Alibaba Cloud Elastic Compute Service !
1. http://iyuluo.com/2017/08/24/%E9%98%BF% ... %E4%B8%80/
阿里云 VPS 开启之路之一
删除阿里云登录界面欢迎信息
使用apt-get -f install更新提示
2. 如果是 非 root 使用者登入
sudo apt-get -f install

3. 在 Ubuntu
新手 不建議 使用 root 登入
回复

回到 “新立得和软件源”