当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : apt-get remove libglib2.0-0,导致系统崩溃
帖子发表于 : 2018-04-23 13:06 

注册: 2018-04-20 14:31
帖子: 4
系统: ubuntu16.04
送出感谢: 1
接收感谢: 0 次
背景:用apt-get install 安装包时总是会出现各种依赖问题,例如apt-get -f install openssh-service,后来发现有一部分是依赖包的版本太高所致删除该依赖包再重新安装即可。之后apt-get -f install libgtk2.0-dev时也报依赖问题,我也用了这种删报错依赖包的方法,apt-get remove libglib2.0-0,发现它把很多包都删掉了,系统直接崩溃,后来做在一个镜像系统中做现象复原问题重现时发现,总共删了645个包。
问题:
为什么apt-get remove libglib2.0-0,会删除这么多包??(网上绝大多数博客都说只会删除指定的包,查到过某个博客说是删除指定包以及依赖它的其他包,翻阅ubuntu wiki没有找到相关描述,特来求证一下)


页首
 用户资料  
 
2 楼 
 文章标题 : Re: apt-get remove libglib2.0-0,导致系统崩溃
帖子发表于 : 2018-04-23 15:37 

注册: 2009-08-04 16:33
帖子: 17780
送出感谢: 21
接收感谢: 1914
引用:
为什么apt-get remove libglib2.0-0,会删除这么多包??

1. 在 Ubuntu
1-1. 安裝某個套件 會將該套件的相依套件及推薦套件 自動同時安裝
1-1-1. sudo apt-rdepends 某個套件名稱
會列印出來 所有該套件的遞迴相依套件及遞迴推薦套件

1-2. 移除某個套件 可能會將遞迴依賴於該套件的所有已安裝套件 自動同時移除 (講可能 因為還有其它影響因素 在此暫時略過)
1-2-1. sudo apt-rdepends -r 某個套件名稱
會列印出來 所有遞迴依賴於該套件的套件 (包含已安裝及未安裝)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译