当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]No apache MPM package installed
帖子发表于 : 2008-02-15 11:19 

注册: 2008-01-25 14:55
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
弱弱的问一下
$ sudo apt-get install subversion

$ sudo apt-get install libapache2-svn
均已完成

sudo /etc/inid.d/apache2 restart 时失败
提示:No apache MPM package installed

请问这要安装什么? 非常感谢!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-02-15 12:02 
头像

注册: 2006-07-19 22:31
帖子: 56
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install apache2-mpm-*
有几个不同的,你选一个


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-02-15 12:04 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install apache2 你的apache2有安装吗?


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-02-15 14:51 

注册: 2008-01-25 14:55
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
谢谢!! 现在可以运行,但是有新的问题提示,麻烦帮忙看一下:

sting@sting-desktop:/etc/init.d$ sudo /etc/init.d/apache2 restart
* Restarting web server apache2
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName

然后在浏览器中输入
http://localhost
http://127.0.1.1:80
都会显示“It Works!”

请问 这有是什么呢?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-02-15 23:01 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
这个是正常现象. 控制台出现这个提示只需要编辑 /etc/apache2/http.conf 最后加上 ServerName 127.0.0.1 就可以了, 不改其实也没有太大关系.

浏览器的提示就是表示apache正常工作了.


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
6 楼 
 文章标题 : Re:
帖子发表于 : 2012-11-07 13:59 

注册: 2011-08-09 15:14
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
daviszhao 写道:
sudo apt-get install apache2-mpm-*
有几个不同的,你选一个



出现如下问题怎么解决呢,菜鸟求大神帮助
下列软件包有未满足的依赖关系:
apache2-mpm-event : 冲突: apache2-mpm
apache2-mpm-itk : 冲突: apache2-mpm
apache2-mpm-prefork : 冲突: apache2-mpm
apache2-mpm-worker : 冲突: apache2-mpm
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: Re:
帖子发表于 : 2013-06-11 9:35 

注册: 2013-06-11 9:20
帖子: 1
系统: centos+ubuntu
送出感谢: 0 次
接收感谢: 0 次
yinxiao 写道:
daviszhao 写道:
sudo apt-get install apache2-mpm-*
有几个不同的,你选一个



出现如下问题怎么解决呢,菜鸟求大神帮助
下列软件包有未满足的依赖关系:
apache2-mpm-event : 冲突: apache2-mpm
apache2-mpm-itk : 冲突: apache2-mpm
apache2-mpm-prefork : 冲突: apache2-mpm
apache2-mpm-worker : 冲突: apache2-mpm
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。



Apache有两种MPM的工作模式,你只要选择其中的一种即可,apt-get install apach2-mpm-worker或者apt-get install apach2-mpm-prefork.具体这两种之间的区别,你可以去Apache官方wiki查看。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译