当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]lighttpd 下rails 启动不了
帖子发表于 : 2008-02-21 20:22 

注册: 2007-03-25 21:21
帖子: 67
送出感谢: 0 次
接收感谢: 0 次
引用:
* Stopping web server lighttpd [ OK ]
* Starting web server lighttpd [ OK ]
cai@lover:~/www/rails/demo/public$ 2008-02-21 20:23:05: (mod_fastcgi.c.1043) the fastcgi-backend /home/cai/www/rails/demo/public/dispatch.fcgi failed to start:
2008-02-21 20:23:05: (mod_fastcgi.c.1047) child exited with status 1 /home/cai/www/rails/demo/public/dispatch.fcgi
2008-02-21 20:23:05: (mod_fastcgi.c.1050) If you're trying to run PHP as a FastCGI backend, make sure you're using the FastCGI-enabled version.
You can find out if it is the right one by executing 'php -v' and it should display '(cgi-fcgi)' in the output, NOT '(cgi)' NOR '(cli)'.
For more information, check http://trac.lighttpd.net/trac/wiki/Docs ... -programIf this is PHP on Gentoo, add 'fastcgi' to the USE flags.
2008-02-21 20:23:05: (mod_fastcgi.c.1354) [ERROR]: spawning fcgi failed.
2008-02-21 20:23:05: (server.c.895) Configuration of plugins failed. Going down.


这个是给出的错误信息
引用:
$HTTP["host"] =="rails"{
server.document-root = "/home/cai/www/rails/demo/public/"
url.rewrite = ( "^/$"=>"index.html","^([^.]+)$"=> "$1.html")
server.error-handler-404 = "/dispatch.fcgi"
fastcgi.server = ( ".fcgi" =>
("rails"=>
("min-procs"=> 2,
"max-procs"=> 2,
"socket"=> "/tmp/rails.fcgi.socket",
"bin-path"=> "/home/cai/www/rails/demo/public/dispatch.fcgi",
"bin-environment"=> ( "RAILS_ENV" => "development")
)
)
)
}

这里是rails的配置

到底哪里错了?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译