[问题]apt-get install apache2的时候出现问题

Web、Mail、Ftp、DNS、Proxy、VPN、Samba、LDAP 等基础网络服务
回复
Havanna
帖子: 813
注册时间: 2008-04-20 12:13
系统: OS X, Gentoo, Win8.1
来自: Shanghai, PRC
送出感谢: 0
接收感谢: 1 次

[问题]apt-get install apache2的时候出现问题

#1

帖子 Havanna » 2008-04-26 12:46

代码: 全选

apple@ubuntu:~$ sudo apt-get  install apache2
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
将会安装下列额外的软件包:
  apache2-mpm-worker apache2-utils apache2.2-common libapr1 libaprutil1
建议安装的软件包:
  apache2-doc
下列【新】软件包将被安装:
  apache2 apache2-mpm-worker apache2-utils apache2.2-common libapr1
  libaprutil1
共升级了 0 个软件包,新安装了 6 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 1354kB 的软件包。
After this operation, 4878kB of additional disk space will be used.
您希望继续执行吗?[Y/n]y
【警告】:下列的软件包不能通过验证!
  libapr1 libaprutil1 apache2-utils apache2.2-common apache2-mpm-worker
  apache2
不经验证就安装这些软件包么?[y/N] y
错误 http://ubuntu.cn99.com hardy/main libapr1 1.2.11-1
  404 Not Found
错误 http://ubuntu.cn99.com hardy/main libaprutil1 1.2.12+dfsg-3
  404 Not Found
错误 http://ubuntu.cn99.com hardy/main apache2-utils 2.2.8-1
  404 Not Found
错误 http://ubuntu.cn99.com hardy/main apache2.2-common 2.2.8-1
  404 Not Found
错误 http://ubuntu.cn99.com hardy/main apache2-mpm-worker 2.2.8-1
  404 Not Found
错误 http://ubuntu.cn99.com hardy/main apache2 2.2.8-1
  404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main/a/apr/libapr1_1.2.11-1_i386.deb  404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main/a/apr-util/libaprutil1_1.2.12+dfsg-3_i386.deb  404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main/a/apache2/apache2-utils_2.2.8-1_i386.deb  404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main/a/apache2/apache2.2-common_2.2.8-1_i386.deb  404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main/a/apache2/apache2-mpm-worker_2.2.8-1_i386.deb  404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main/a/apache2/apache2_2.2.8-1_all.deb  404 Not Found
改如何安装呢?

版本是Linux ubuntu 2.6.24-16-generic
Havanna
帖子: 813
注册时间: 2008-04-20 12:13
系统: OS X, Gentoo, Win8.1
来自: Shanghai, PRC
送出感谢: 0
接收感谢: 1 次

#2

帖子 Havanna » 2008-04-26 12:47

换了官方源仍然是这种情况
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#3

帖子 dbzhang800 » 2008-04-26 12:52

Havanna 写了:换了官方源仍然是这种情况
cn99的硬盘坏了。

至于你说换了官方源还是这样,我就不信了。
官方源会去连 cn99 ?
还是你
换源后没刷新??
Havanna
帖子: 813
注册时间: 2008-04-20 12:13
系统: OS X, Gentoo, Win8.1
来自: Shanghai, PRC
送出感谢: 0
接收感谢: 1 次

#4

帖子 Havanna » 2008-04-26 13:00

dbzhang800 写了:
Havanna 写了:换了官方源仍然是这种情况
cn99的硬盘坏了。

至于你说换了官方源还是这样,我就不信了。
官方源会去连 cn99 ?
还是你
换源后没刷新??
换源后apt-get update过了
1楼我贴的是cn99的连接
官方的源也是同样情况,只是换了官方连接而已
Havanna
帖子: 813
注册时间: 2008-04-20 12:13
系统: OS X, Gentoo, Win8.1
来自: Shanghai, PRC
送出感谢: 0
接收感谢: 1 次

#5

帖子 Havanna » 2008-04-26 13:09

今天也是心血来潮,突然想玩下web才发现此问题。。。。
难道一定要手动安装。。。。
回复

回到 “服务器基础应用”