当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [求助]启动dhcp出错:No subnet declaration for eth0 (192.168.0.1)
帖子发表于 : 2008-04-30 14:30 
头像

注册: 2007-04-05 21:22
帖子: 523
送出感谢: 0 次
接收感谢: 0 次
求助,系统是 XUbuntu 8.04 i386。装了dhcp3-server。
使用 sudo /etc/init.d/dhcp3-server start 出错:
Apr 30 14:24:03 s dhcpd: Wrote 0 leases to leases file.
Apr 30 14:24:03 s dhcpd:
Apr 30 14:24:03 s dhcpd: No subnet declaration for eth0 (192.168.0.1).
Apr 30 14:24:03 s dhcpd: ** Ignoring requests on eth0. If this is not what
Apr 30 14:24:03 s dhcpd: you want, please write a subnet declaration
Apr 30 14:24:03 s dhcpd: in your dhcpd.conf file for the network segment
Apr 30 14:24:03 s dhcpd: to which interface eth0 is attached. **
Apr 30 14:24:03 s dhcpd:
Apr 30 14:24:03 s dhcpd:
Apr 30 14:24:03 s dhcpd: Not configured to listen on any interfaces!

系统的 eth0 连接内网
inet 地址:192.168.0.1 广播:192.168.0.255 掩码:255.255.255.0
系统的 eth1 连接外网

/etc/dhcpd.conf 内容为

option subnet-mask 255.255.255.000;
default-lease-time 600;
max-lease-time 7200;
log-facility local7;

subnet 192.168.0.0 netmask 255.255.255.0 {
range 192.168.0.101 192.168.0.200;
option routers 192.168.0.1;
option broadcast-address 192.168.0.255;
option ip-forwarding off;
}

不知道为什么,已经 touch /var/lib/dhcp3/dhcpd.leases 了。
/etc/default/dhcp3-server 内容为 INTERFACES="eth0"

请问该怎么办啊?

先谢谢了!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-30 14:32 
头像

注册: 2007-04-05 21:22
帖子: 523
送出感谢: 0 次
接收感谢: 0 次
晕死了,解决了。原来配置文件不是 /etc/dhcpd.conf, 是/etc/dhcp3/dhcpd.conf :(


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译