当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]pure-ftpd 怎样把目录设置到移动硬盘?
帖子发表于 : 2008-06-06 20:55 

注册: 2008-06-06 20:53
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
在debian系统下设置好了,ftp也可以正常访问了,但就是无法显示移动硬盘上的文件,显示无法读取/media/usb0中的文件。
是什么原因?该怎样解决啊?

移动硬盘(暂用u盘代替)分区格式为fat32,可以ls/dir读取的

我把登陆的信息抄过来,高手们帮我看看那里没有配置好:

1. 建站配置
roupadd ftpusers –g 2000
添加FTP用户组
useradd ftp -u 2000 -g ftpusers -s /sbin/nologin

pure-pw useradd sunftp -u ftp -d /media/usb0 -f /etc/pure-ftpd/pureftpd.passwd
运行之后输入 sunftp用户的密码。

生成密码数据库
pure-pw mkdb /etc/pure-ftpd/pureftpd.pdb -f /etc/pure-ftpd/pureftpd.passwd
然后重启系统

2.登陆信息
登陆ok,然后使用ls/dir命令,显示信息如下:
port command successful
connecting to port 41153
sorry ,we were unable to read[.]
options: -l
0 matches total

我试着更改ftp工作目录,改为:/media,情况还是一样,无法显示移动硬盘(u盘上的文件)

是不是系统重启的时候,usb驱动还没有加载(盘符/目录还没有分配?),造成ftp无法找到我设置的目录(ftp自启动)

查看了系统日志,摘要如下:
pure-ftpd:sunftpd is now logged in
pure-ftpd:can't change directory to usb0:permission denied
pure-ftpd:logout


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-06-10 16:22 

注册: 2008-06-06 20:53
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
请问:如何设置才能让非根用户,访问usb设备(目录)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译