我用evolution收信发现一个奇怪的现象

Web、Mail、Ftp、DNS、Proxy、VPN、Samba、LDAP 等基础网络服务
回复
头像
goldfox_79
帖子: 1937
注册时间: 2005-10-16 8:26
来自: 地球
送出感谢: 0
接收感谢: 1 次
联系:

我用evolution收信发现一个奇怪的现象

#1

帖子 goldfox_79 » 2006-04-16 4:57

有些邮件标题显示为乱码,但是邮件内容显示正确,不解?有谁遇到过这样的问题吗?
头像
chinux
帖子: 282
注册时间: 2005-05-31 23:53
来自: 天府之国
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 chinux » 2006-04-16 7:47

这很正常,不同地址发过来的邮件用的编码方式不一样,像163用的是GB2132,而Gmail基本上用的是utf-8。你的evolution选择一种编码查看这些邮件,肯定会有乱码。什么时候中文能够“车同规,文同种”啊
寂寂寒月夜,孤坐伴清灯。曳曳烛光摇,淡淡数点星。
起身动瑶佩,移步出门去。默默倚危阑,遥听伊人语。
头像
goldfox_79
帖子: 1937
注册时间: 2005-10-16 8:26
来自: 地球
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 goldfox_79 » 2006-04-16 12:27

chinux 写了:这很正常,不同地址发过来的邮件用的编码方式不一样,像163用的是GB2132,而Gmail基本上用的是utf-8。你的evolution选择一种编码查看这些邮件,肯定会有乱码。什么时候中文能够“车同规,文同种”啊
不对啊,同一封邮件,标题显示乱码,内容显示正确,难道同一封信标题和内容的编码还不相同
上次由 goldfox_79 在 2006-10-11 12:51,总共编辑 1 次。
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#4

帖子 firehare » 2006-04-17 17:13

这个也很正常,如果你的系统是用 UTF-8 而你的信件是用GB2312的话!因为查看编码是只对信件体发生作用的!
我心无畏,源自于我心无知。
图片
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2006-04-17 18:15

还会有其他地方这样的。碰几次就知道了。
● 鸣学
Skip'toMyLou
帖子: 55
注册时间: 2006-04-16 16:27
来自: Hong Kong
送出感谢: 0
接收感谢: 0

#6

帖子 Skip'toMyLou » 2006-04-19 9:36

我的邮箱就是这样的,还是 Graffiti.net 的。
头像
yinliang108
帖子: 964
注册时间: 2005-10-01 21:38
来自: 湖南邵东流光岭
送出感谢: 0
接收感谢: 0
联系:

同一个信箱用firefox写的信件就没问题,用evolution发送的就有问题啊!!!

#7

帖子 yinliang108 » 2006-06-03 23:28

我用evolution发送邮件给我自己的一个信箱,我自己用firefox打开就有问题,用firefox直接打开信箱给自己发送一个邮件,再打开就没有问题!!真是奇怪了。
小江恩的博客
http://gann.blog.ifeng.com/
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#8

帖子 firehare » 2006-06-06 11:09

同样还是编码问题、

你用 evolution 发送时你的 local 是什么编码?
而你的信箱用的又是什么编码 ?

你用 Firefox 发信后用 firefox 打开没有问题
那么你用 evolution 发信后用 evolution 收的话看看是否有问题 ?
我心无畏,源自于我心无知。
图片
fuoren
帖子: 208
注册时间: 2006-02-12 22:24
送出感谢: 0
接收感谢: 0
联系:

关于乱码问题

#9

帖子 fuoren » 2006-06-23 20:49

最好登陆网站,用firefox在网页里收发邮件,不会有乱码问题
回复

回到 “服务器基础应用”