当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [问题]Apache 2httpd.conf的问题
帖子发表于 : 2008-08-16 2:23 
头像

注册: 2008-08-14 0:53
帖子: 95
送出感谢: 0 次
接收感谢: 0 次
大家好,我是刚换到用Ubuntu的行列中的。
以前用别的版本。

我的是Server Edition

apache2目录里有个apche2.conf ,我看在unbuntu里是配置这个。
我读了一下这个文件。
发现是把httpd.conf和一些模块的配置文件引用到这里的。
我不理解的是httpd.conf是空的。
apache2.conf 文件里写的是引用所有用户的配置


请大家帮我解释下


谢谢!!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-18 19:02 
头像

注册: 2008-08-04 23:27
帖子: 79
地址: Hong Kong
送出感谢: 0 次
接收感谢: 0 次
因为,所以。。。。。。。。

人家不喜欢httpd.conf了,所以就用了apache2.conf 了。


_________________
"Those who excel in beauty become vain; those who excel in strength become violent."


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-19 0:13 
头像

注册: 2008-08-14 0:53
帖子: 95
送出感谢: 0 次
接收感谢: 0 次
:ema3

楼上的兄弟,你的httpd.conf也是空的么?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-19 13:26 
头像

注册: 2008-08-04 23:27
帖子: 79
地址: Hong Kong
送出感谢: 0 次
接收感谢: 0 次
JCheung 写道:
:ema3

楼上的兄弟,你的httpd.conf也是空的么?


谁的也一样,他们不喜欢httpd.conf


_________________
"Those who excel in beauty become vain; those who excel in strength become violent."


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-09-11 21:18 

注册: 2008-09-11 20:54
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
我的也是空的!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-09-12 15:49 

注册: 2007-10-04 18:46
帖子: 81
送出感谢: 0 次
接收感谢: 0 次
我的也是空的..............不习惯


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-09-13 1:19 
头像

注册: 2008-08-14 0:53
帖子: 95
送出感谢: 0 次
接收感谢: 0 次
ccqqwheat 写道:
我的也是空的..............不习惯


同感!
改的东西挺多的。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: [问题]Apache 2httpd.conf的问题
帖子发表于 : 2008-11-20 13:52 

注册: 2008-11-16 11:57
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
 我按照wiki关于8.04安装lamp的方法在8.10上安装了lamp
  我在www文件夹下建立了一个名为bob的文件夹,里面新建了index. html firefox下localhost可以输出IT WORKS
  但地址栏打入locaihost/bob就出现错误403
  Forbidden
  You don't have permission to access /bob/ on this server.
  Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4 with Suhosin-Patch Server at localhost Port 80
  
  
  我用chmod755给bob加权限 也不行
  网上说在httpd.conf中把
  <Directory />
  Options FollowSymLinks
  AllowOverride None
  Order deny,allow
  deny from all
  Satisfy all
  </Directory>
  deny from all中的deny改成了allow,
  保存后重启apache
  
  
  今天我找到httpd。conf,里面是空的。就在apache2.conf中把deny改成了allow,没用。
  
  请问我该怎么做呢?


页首
 用户资料  
 
9 楼 
 文章标题 : Re: [问题]Apache 2httpd.conf的问题
帖子发表于 : 2008-11-20 17:58 
头像

注册: 2008-11-20 12:57
帖子: 30
送出感谢: 0 次
接收感谢: 1
LZ不说我还真没留意到


_________________
弃我去者 昨日之日不可留
乱我心者 今日之日多烦忧


页首
 用户资料  
 
10 楼 
 文章标题 : Re: [问题]Apache 2httpd.conf的问题
帖子发表于 : 2008-11-20 18:10 
头像

注册: 2008-10-18 12:41
帖子: 1339
送出感谢: 0 次
接收感谢: 0 次
没看到apache2.conf里面有inclues吗。。想不想用随便你
不过好像有一些只能加到httpd.conf才能用


_________________
Server@Linux:~#


页首
 用户资料  
 
11 楼 
 文章标题 : Re: [问题]Apache 2httpd.conf的问题
帖子发表于 : 2008-11-22 18:45 
头像

注册: 2006-07-10 16:38
帖子: 176
送出感谢: 0 次
接收感谢: 1
whywhatwhenhow 写道:
 我按照wiki关于8.04安装lamp的方法在8.10上安装了lamp
  我在www文件夹下建立了一个名为bob的文件夹,里面新建了index. html firefox下localhost可以输出IT WORKS
  但地址栏打入locaihost/bob就出现错误403
  Forbidden
  You don't have permission to access /bob/ on this server.
  Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4 with Suhosin-Patch Server at localhost Port 80
  
  
  我用chmod755给bob加权限 也不行
  网上说在httpd.conf中把
  <Directory />
  Options FollowSymLinks
  AllowOverride None
  Order deny,allow
  deny from all
  Satisfy all
  </Directory>
  deny from all中的deny改成了allow,
  保存后重启apache
  
  
  今天我找到httpd。conf,里面是空的。就在apache2.conf中把deny改成了allow,没用。
  
  请问我该怎么做呢?


将bob文件夹的owner设为www-data:www-data,即设为www-data组www-data用户所有试试


_________________
http://blog.ranfow.cn/


页首
 用户资料  
 
12 楼 
 文章标题 : Re: [问题]Apache 2httpd.conf的问题
帖子发表于 : 2008-12-07 13:12 
头像

注册: 2008-07-14 16:40
帖子: 291
送出感谢: 0 次
接收感谢: 0 次
2楼的兄弟来自绍兴兰亭?


页首
 用户资料  
 
13 楼 
 文章标题 : Re: [问题]Apache 2httpd.conf的问题
帖子发表于 : 2009-01-02 12:44 

注册: 2006-10-18 0:57
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
whywhatwhenhow 写道:
 我按照wiki关于8.04安装lamp的方法在8.10上安装了lamp
  我在www文件夹下建立了一个名为bob的文件夹,里面新建了index. html firefox下localhost可以输出IT WORKS
  但地址栏打入locaihost/bob就出现错误403
  Forbidden
  You don't have permission to access /bob/ on this server.
  Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4 with Suhosin-Patch Server at localhost Port 80
  
  
  我用chmod755给bob加权限 也不行
  网上说在httpd.conf中把
  <Directory />
  Options FollowSymLinks
  AllowOverride None
  Order deny,allow
  deny from all
  Satisfy all
  </Directory>
  deny from all中的deny改成了allow,
  保存后重启apache
  
  
  今天我找到httpd。conf,里面是空的。就在apache2.conf中把deny改成了allow,没用。
  
  请问我该怎么做呢?


_________________
AMD Athlon x2 3600+
捷波悍马HAO1-GT
斯巴达克X1650GT
Ubuntu 7.04 xgl+beryl


最后由 byg1228 编辑于 2009-01-02 22:14,总共编辑了 1 次

页首
 用户资料  
 
14 楼 
 文章标题 : Re: [问题]Apache 2httpd.conf的问题
帖子发表于 : 2009-01-02 12:52 

注册: 2006-10-18 0:57
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
JCheung 写道:
大家好,我是刚换到用Ubuntu的行列中的。
以前用别的版本。

我的是Server Edition

apache2目录里有个apche2.conf ,我看在unbuntu里是配置这个。
我读了一下这个文件。
发现是把httpd.conf和一些模块的配置文件引用到这里的。
我不理解的是httpd.conf是空的。
apache2.conf 文件里写的是引用所有用户的配置


请大家帮我解释下


谢谢!!


这样做是把用户自己的配置单独出来,有意和系统的配置加以区分,
你要有什么样的额外配置就放在httpd.conf里,不用去修改apache2.conf
这么做很好!


_________________
AMD Athlon x2 3600+
捷波悍马HAO1-GT
斯巴达克X1650GT
Ubuntu 7.04 xgl+beryl


页首
 用户资料  
 
15 楼 
 文章标题 : Re: [问题]Apache 2httpd.conf的问题
帖子发表于 : 2009-05-30 2:06 
头像

注册: 2009-05-26 14:09
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
请问LZ现在您解决这个问题了吗?
小弟所9.04的系统,是个新手。可否不吝赐教!!
先谢过!! :em51 :em50 :em51 :em51 :em51


_________________
[size=200]含泪播种的人,一定会含笑收获!!![/size]


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译