ubuntu 8.10 安装openssh-server不成功

Web、Mail、Ftp、DNS、Proxy、VPN、Samba、LDAP 等基础网络服务
回复
wdx-snail
帖子: 3
注册时间: 2008-11-03 17:39
送出感谢: 0
接收感谢: 0

ubuntu 8.10 安装openssh-server不成功

#1

帖子 wdx-snail » 2008-11-07 20:50

~$ sudo apt-get install openssh-server
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
openssh-server: 依赖: openssh-client (= 1:5.1p1-1ubuntu1) 但是 1:5.1p1-3ubuntu1 正要被安装
E: 无法安装的软件包

有什么办法吗?
poet
帖子: 2841
注册时间: 2006-09-11 22:47
送出感谢: 0
接收感谢: 4 次

Re: ubuntu 8.10 安装openssh-server不成功

#2

帖子 poet » 2008-11-07 21:06

sudo apt-get update 一下
如果不行,就换个源。

这个一般是因为源的问题,或者是本地的缓存问题。
yinsuntoday
帖子: 48
注册时间: 2008-09-10 15:12
送出感谢: 0
接收感谢: 0

Re: ubuntu 8.10 安装openssh-server不成功

#3

帖子 yinsuntoday » 2008-11-10 15:54

是源的问题!
sudo gedit /etc/apt/sources.list

deb http://archive.ubuntu.com/ubuntu intrepid universe
deb-src http://archive.ubuntu.com/ubuntu intrepid universe
deb http://archive.ubuntu.com/ubuntu intrepid-updates universe
deb http://security.ubuntu.com/ubuntu intrepid-security universe
deb-src http://security.ubuntu.com/ubuntu intrepid-security universe
deb http://archive.ubuntu.com/ubuntu intrepid multiverse
deb http://archive.ubuntu.com/ubuntu intrepid-updates multiverse
deb-src http://archive.ubuntu.com/ubuntu intrepid-updates multiverse
deb-src http://security.ubuntu.com/ubuntu intrepid-security multiverse
deb http://archive.ubuntu.com/ubuntu intrepid main restricted
deb-src http://archive.ubuntu.com/ubuntu intrepid main restricted
deb http://security.ubuntu.com/ubuntu intrepid-security main restricted
deb-src http://security.ubuntu.com/ubuntu intrepid-security main restricted
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ hardy main restricted universe multiverse

deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ hardy main restricted universe multiverse

deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ hardy-updates main restricted universe multiverse

deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ hardy-updates main restricted universe multiverse

deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ hardy-backports main restricted universe multiverse

deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ hardy-backports main restricted universe multiverse

deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ hardy-security main restricted universe multiverse

deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ hardy-security main restricted universe multiverse

deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ hardy-proposed main multiverse restricted universe

deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ hardy-proposed main restricted universe multiverse

deb http://archive.ubuntu.org.cn/ubuntu-cn/ hardy main restricted universe multiverse
改为上面的源试试!
回复

回到 “服务器基础应用”