当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 哪位朋友说说怎么怎么搭建PHP
帖子发表于 : 2008-11-18 13:40 
头像

注册: 2007-12-05 18:32
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
首先是不是要下载apache,能不能用tomcat的呢,apache 我也下载好了,不知道怎么解压安装,apache好像只是一个web服务器,php是不是也要单独下载呢,谁提供一下步骤


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 哪位朋友说说怎么怎么搭建PHP
帖子发表于 : 2008-11-18 21:53 
头像

注册: 2008-09-08 14:41
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
1、安装Apache2
代码:
sudo apt-get install apache2

2、编辑/etc/apache2/apache2.conf文件,在改动之前,请先将该配置文件做个备份。以便在出错的时候可以恢复。
>AddDefaultCharset ISO-8859-1 =>AddDefaultCharset GB2312
这样的话,我们就不会每次打开网页都是乱码了!
3、增加安全模块,以保障Apache服务的正常运行,现在我们安装mod-security。
a)首先安装libapache2-mod-security包
代码:
sudo apt-get install libapache2-mod-security


b)该模块默认是没激活的,我们可以在/etc/apache2/mods-available目录下看到有mod-security.load文件,但在/etc/apache2/mods-enabled目录却没有它的软链接。我们现在激活它:
$sudo ln -s /etc/apache2/mods-available/mod-security.load /etc/apache2/mods-enabled/mod-security.load
$sudo cp /usr/share/doc/libapache2-mod-security/examples/httpd2.conf.example-full /etc/apache2/mods-available/mod-security.conf
$sudo cp /etc/apache2/mods-available/mod-security.conf /etc/apache2/mods-available/mod-security.conf.orig
$sudo vi /etc/apache2/mods-available/mod-security.conf
># 检测内容长度以避免堆溢出攻击
>SecFilterForceByteRange 32 254 =>SecFilterForceByteRange 32 126

># debug设置
>SecFilterDebugLevel 9 =>SecFilterDebugLevel 0

># 设置缺省的动作
>SecFilterDefaultAction "deny,log,status:499" =>SecFilterDefaultAction "deny,log,status:404"

># 把设置传递给子目录
>SecFilterInheritance Off

># Redirect user on filter match
># 当匹配sh的时候,重新定向到一个特殊的警告页面,该页面是自行编写的,写些警告的话让攻击者知难而退,该段先不要生效,等到相关配置配好之后再失效不迟。记住在配好之后要使之生效。
>#SecFilter sh redirect:http://localhost/hack/warning.htm

># Prevent OS specific keywords
>#过滤一些敏感的东西,我们使用*是为了攻击者使用/etc/./passwd来绕开检测
>SecFilter /etc/passwd =>SecFilter /etc/*passwd
>SecFilter /bin/*sh

># Very crude filters to prevent SQL injection attacks
># 防止SQL插入(SQL Injection)攻击
>SecFilter "delete[[:space:]]+from"
>SecFilter "insert[[:space:]]+into"
>SecFilter "select.+from"
>SecFilter "select[[:space:]]+from"
>SecFilter "union[[:space:]]+from"
代码:
sudo ln -s /etc/apache2/mods-available/mod-security.conf /etc/apache2/mods-enabled/mod-security.conf


c)重启Apache2服务即可。
代码:
sudo /etc/init.d/apache2 restart


第三步可能会引起部分网站不能正常运行,可以参照着去掉某些限制,由于是安全模块,所以参照的是防火墙的做法,关掉一切不安全的,再根据需要打开必要的。
1.将系统更新到最新状态,在做任何操作之前都要做这一步,以确保系统的稳定,同时也不会有一些莫名其妙的现象出现。
$sudo apt-get update
$sudo apt-get dist-upgrade

2、安装PHP支持

$sudo apt-get install libapache2-mod-php5
$sudo apt-get install php5
如果想支持图形就加php5-gd,如果想支持Mysql就加php5-mysql,这里之所以要单独列出libapache2-mod- php5,主要是由于php5的依赖关系没有做好,有可能会安装上libapache-mod-php5的包,所以为了避免不必要的麻烦,干脆还是单独指 定比较好。

3、修改PHP配置文件,以限制内存和文件最大上传尺寸

我们编辑/etc/php5/apache2/php.ini文件,先做一般配置,在改动之前,请先将该配置文件做个备份。以便在出错的时候可以恢复。
>memory_limit = 8M =>修改成你所需的内存大小
>upload_max_filesize = 2M =>修改文件最大上传尺寸
=============
>extension=mysql.so 支持Mysql服务
>extension=gd.so 支持gd函数
=============
其实在Ubuntu下,如果你安装了php5-mysql和php5-gd之后,会自动修改以上二行的,我们做的只不过是确认一下它们前面的注释符是否去掉。
bobyang 写道:
补充:
1。目前大多数php的open source都是用php4写的,为了兼容以前的php版本,有时需要将register_long_arrays打开,否则$HTTP_GET_VARS和$HTTP_POST_VARS等变量将无法使用,会出现一些莫名其妙的问题。
2。另外,在装完php5后最好确认一下/etc/apache2/mods-enabled/下是否有链接:
php5.load -> /etc/apache2/mods-available/php5.load


4、加固PHP,以增强安全性。注意,下面的安全性要因情况而定,所以我已经把它们的功能写清楚了,如果有问题的话,看看是否由于下面哪种限制条件所造成,可相应将其注释掉。

下面我们开始加固php,我们再次编辑/etc/php5/apache2/php.ini文件,之所以没有一次改完,主要是为了给大家一个清晰的思路。
>#打开安全模式,打开他的好处就是PHP文件只能访问所有者和PHP文件所有着一样的文件,即使在chroot环境下也无法访问jail 中属主不一样的文件,类似于php shell这样的后门就没用武之地了哦,phpshell是很流行的php后门,他可以执行系统命令,就象他的名字一样,和shell很接近。
>safe_mode = On

>#下面的设置就限制了fopen(), file()等函数可以操作的目录范围,避免了入侵者非法读取文件,一定要在/var/www后面加"/",否则/var/wwww下的文件也能被访问 。该选项会禁止任何不在/var/www/目录下的PHP文件运行,包括任何以软链接方式链到/var/www/目录下的程序,如PhpMyAdmin 包,就在该选项设定后无法正常运行。
>open_basedir = /var/www/

>#禁止使用phpinfo和get_cfg_var函数,这样可以避免泄露服务信息,一般在在确认PHP能正常工作之后再使之关闭
>disable_functions = phpinfo,get_cfg_var

>#设置php程序错误日志
>error_reporting = E_ALL
>log_errors = On
>error_log = /var/log/php_err.log

>#如果php程序没有指明需要register_globals的话,最好把register_globals设置为Off,这样可以避免很多安全问题的。注意,如果你的程序是需要register_globals的话,可千万别关。Ubuntu默认是关闭的。
>register_globals = Off

>#禁止打开远程地址,记得最近出的php include的那个漏洞吗?就是在一个php程序中include了变量,那么入侵者就可以利用这个控制服务器在本地执行远程的一个php程序,例如phpshell,所以我们关闭这个。
>allow_url_fopen = Off

5、OK,打完收功!


_________________
长沙UBUNTU QQ群 42441115


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 哪位朋友说说怎么怎么搭建PHP
帖子发表于 : 2008-11-19 1:23 
头像

注册: 2007-12-05 18:32
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
不是说了吗不用apt-get这方式


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 哪位朋友说说怎么怎么搭建PHP
帖子发表于 : 2008-11-19 8:36 
头像

注册: 2007-12-05 18:32
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
2楼的朋友明显是在哪里去copy的


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 哪位朋友说说怎么怎么搭建PHP
帖子发表于 : 2008-11-19 9:57 
头像

注册: 2006-10-25 18:10
帖子: 2677
地址: 长沙
送出感谢: 0 次
接收感谢: 0 次
搞那么麻烦干嘛,装一个 XAMPP 就行了。源里面有。


_________________
你是自由的。别人也是。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 哪位朋友说说怎么怎么搭建PHP
帖子发表于 : 2008-11-19 14:17 
头像

注册: 2007-11-26 19:10
帖子: 204
地址: 浙江省
送出感谢: 0 次
接收感谢: 0 次
楼上的你们太麻烦了。
如果是服务器版本,安装的时候选择LAMP 就可以了

如果是桌面版本,到新立得软件仓库中,选择按任务分组,就可以找到LAMP软件组合,标记一下,再应用,直接安装就好了,自动全部支持。
默认是不安装php5-gd 库,可以用以下命令安装一下
sudo ap-get install php5-gd


_________________
代码:
# sudo apt-get --help
# .....
# remove 删除
# install 安装
# 本 APT 具有超级牛力。
# sudo apt-get remove window* && sudo apt-get install ubuntu && sudo init 1
# ......
# 正在为您配置NB的系统...
# 系统正在为您关机.....


Linux水吧


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译