当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : lamp中用wordpress看不到排版效果和图片
帖子发表于 : 2009-03-17 23:25 

注册: 2007-04-27 16:07
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
我是按照wiki中的说明来装上lamp的,设置什么的都搞好了,权限wordpress设为777,phpmyadmin设为755,
但用wordpress写了东西,在别人的机上看,CSS的效果完全看不到的,上传了图片别人也看不到,但在本机看却完全正常。
附图如下:

别人主机上看的:
附件:
{7DC9F66E-C271-46A7-A06A-6FF8944577E9}0.jpg
{7DC9F66E-C271-46A7-A06A-6FF8944577E9}0.jpg [ 32.13 KiB | 被浏览 1646 次 ]


本机看的效果:
附件:
sendpix1.jpg
sendpix1.jpg [ 64.05 KiB | 被浏览 1640 次 ]



页首
 用户资料  
 
2 楼 
 文章标题 : Re: lamp中用wordpress看不到排版效果和图片
帖子发表于 : 2009-03-18 13:28 

注册: 2007-04-27 16:07
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
人工顶一下,希望可以解决


页首
 用户资料  
 
3 楼 
 文章标题 : Re: lamp中用wordpress看不到排版效果和图片
帖子发表于 : 2009-04-04 13:58 
头像

注册: 2008-02-02 23:05
帖子: 471
地址: 天津
送出感谢: 0 次
接收感谢: 0 次
你的WP安装地址设置错了,不要设置成“http://localhost/WP安装目录”,而应是“http://你的IP/WP安装目录”


_________________
浪漫是一种天赋!!!!


页首
 用户资料  
 
4 楼 
 文章标题 : Re: lamp中用wordpress看不到排版效果和图片
帖子发表于 : 2009-04-10 15:16 
头像

注册: 2008-07-21 9:44
帖子: 2371
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
我也遇到了这种情况,按照ls所说,如果把安装地址设置为“http://你的IP/WP安装目录“,如果哪天IP地址变化了,那博客里链接的图片岂不是显示不了了?觉得这样就很不灵活了,不像phpbb那样随便安装好后既可以通过localhost访问也可以通过IP地址或域名访问。


_________________

My blog


页首
 用户资料  
 
5 楼 
 文章标题 : Re: lamp中用wordpress看不到排版效果和图片
帖子发表于 : 2009-04-10 22:49 
头像

注册: 2008-07-21 9:44
帖子: 2371
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
我貌似知道怎么改了 :em05 :em05
进入blog的后台,应该是在“设置” -> “常规设置”那里修改Wordpress地址(URL)和Blog地址(URL)就行
不过这样只是解决了CSS的问题,图片显示的问题还是不能解决


_________________

My blog


页首
 用户资料  
 
6 楼 
 文章标题 : Re: lamp中用wordpress看不到排版效果和图片
帖子发表于 : 2009-04-12 21:39 

注册: 2009-04-11 13:46
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
需要安装gd库
sudo apt-get install php5-gd
sudo /etc/init.d/apache2 restart


页首
 用户资料  
 
7 楼 
 文章标题 : Re: lamp中用wordpress看不到排版效果和图片
帖子发表于 : 2009-04-12 22:06 
头像

注册: 2008-07-21 9:44
帖子: 2371
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
我详细描述一下这个问题吧,希望有这方面经验的大虾们指点一下:
首先,机器上已经搭建好LAMP的环境了,然后在自己的机器上安装wordpress。
安装的步骤是这样的,用MySQL建立了一个供wordpress连接使用的数据库,修改了一下wordpress目录下的wp-config-sample.php文件并改名为wp-config.php,然后在浏览器中输入http://localhost/wordpress便可顺利完成安装了。现在的问题是在自己的机器上访问wordpress完全没有问题(无论是CSS还是图片的显示都完全没有问题),但是其他人通过IP地址或域名访问这个wordpress时就会出现 LZ 附件中第一幅图的样子(即CSS显示不出来或者说是不起作用吧)。这个问题好办,即按照我在 5L所说的把Wordpress地址(URL)和Blog地址(URL)中的localhost改为自己的IP地址或域名就可以解决了。但是,自己博客中上传的附件(图片)的连接地址却仍然是http://localhost/wordpress/......其他人单击附件(图片)时会提示链接错误什么的(这个是肯定会出错的,因为URL是http://localhost......)所以,这个问题还不知怎么解决。


_________________

My blog


页首
 用户资料  
 
8 楼 
 文章标题 : Re: lamp中用wordpress看不到排版效果和图片
帖子发表于 : 2009-04-13 13:04 

注册: 2008-11-16 14:59
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
请用域名来安装


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译