在ubuntu8.10下配置openldap遇到的问题,请大家帮忙解决~

Web、Mail、Ftp、DNS、Proxy、VPN、Samba、LDAP 等基础网络服务
回复
keome
帖子: 9
注册时间: 2008-03-29 16:06
送出感谢: 0
接收感谢: 0

在ubuntu8.10下配置openldap遇到的问题,请大家帮忙解决~

#1

帖子 keome » 2009-03-22 20:17

上网查了很多教程,在ubuntu下安装openldap如下(似乎):

keegoo@keegoo-desktop:/etc/ldap$ sudo apt-get install slapd ldap-utils
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
将会安装下列额外的软件包:
libdb4.2 odbcinst1debian1 unixodbc
建议安装的软件包:
libmyodbc odbc-postgresql libct1
下列【新】软件包将被安装:
ldap-utils libdb4.2 odbcinst1debian1 slapd unixodbc
共升级了 0 个软件包,新安装了 5 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 2494kB 的软件包。
解压缩后会消耗掉 6701kB 的额外空间。
您希望继续执行吗?[Y/n]


安装结束后,用ps查看,slapd这个守护进程确实在运行,我的问题是:

openldap运行需要数据库支持,刚刚上面的命令并没有安装数据库,而且我用find查找berkeleyDB也没有找到,那openldap用的是什么数据库呢?

或者说我得在安装slapd之前,先安装一个berkeleyDB?
回复

回到 “服务器基础应用”