proftpd使用中文用户名登录,目录访问限制编码问题-恳请高手帮忙!!

Web、Mail、Ftp、DNS、Proxy、VPN、Samba、LDAP 等基础网络服务
回复
disco97
帖子: 1
注册时间: 2008-09-28 14:26
送出感谢: 0
接收感谢: 0

proftpd使用中文用户名登录,目录访问限制编码问题-恳请高手帮忙!!

#1

帖子 disco97 » 2009-04-08 16:25

操作系统:ubuntu8.10server utf8编码
ftp客户端采用cuteftp(不支持UTF8编码),登录用户名采用中文,如“张三”
ftp服务器端目录中文命名。
proftpd1.3.2已经通过源码安装,参数加入--enable-nls,在proftpd.conf中加入UseEncoding UTF-8 GBK ,解决了中文目录显示问题。
用户名验证通过mysql方式也得到解决。
但是限制用户目录访问使用allow语句时,由于proftpd.conf中汉字utf8编码的缘故,客户端无法识别。

<Directory /home/ftp/张三>
<Limit WRITE>
AllowUser 张三
AllowUser sa
DenyAll
</Limit>
</Directory>
winchen
帖子: 3
注册时间: 2009-01-26 0:57
送出感谢: 0
接收感谢: 0

Re: proftpd使用中文用户名登录,目录访问限制编码问题-恳请高手帮忙!!

#2

帖子 winchen » 2010-06-21 14:39

proftpd使用中文用户名登录
我弄了很久 无法中文登入
请教楼主 怎设定的
我的QQ 1157244697
回复

回到 “服务器基础应用”