当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : apt-get install build-essential 错误
帖子发表于 : 2009-04-23 15:31 

注册: 2009-03-05 14:15
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
我在建立编译环境前
输入:


root#apt-get install build-essential

出现错误
can not find package build-essential

请问如何解决


附件:
error.JPG
error.JPG [ 15.39 KiB | 被浏览 2256 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 : Re: apt-get install build-essential 错误
帖子发表于 : 2009-04-23 15:34 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
你有没有换源,有没有先update,再upgrade,然后再装软件?至少我看到你的包名打错了。最好照wiki的包名粘贴过来。 :em06


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: apt-get install build-essential 错误
帖子发表于 : 2009-04-23 15:53 

注册: 2009-03-05 14:15
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
恩,包名打对,也是相同的错误。

你能把换源,有没有先update,再upgrade。。步骤具体说一下吗


页首
 用户资料  
 
4 楼 
 文章标题 : Re: apt-get install build-essential 错误
帖子发表于 : 2009-04-23 16:02 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
安装完成后,先看wiki
http://wiki.ubuntu.org.cn
认真照Wiki配置,还有问题上Ubuntu中文论坛找贴发问!纯新手,最好下DVD版本的ISO,再刻盘安装,安装时断网安装,最省事!
特别要细看Qref(快速设置指南,注意版本选择!),还有热门设置的一些条目,认真看,照着做,可以解决你90%以上的问题。
照wiki的方法执行换源,可以在图形界面完成,也可以用命令行:
sudo cp /etc/apt/sources.list /etc/apt/sources.listbak
sudo gedit /etc/apt/sources.list
把你看到的内容删除,从wiki上看到的适合你版本和你的宽带线路的源表粘贴过来就行了,顺便补个空行,养成好习惯。
然后,在终端下:
sudo apt-get update
更新源表完成后,再执行:
sudo apt-get upgrade
完成整个系统更新后,重启电脑。
然后想装什么包,就装什么包吧,不要搞错包名。 :em06


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: apt-get install build-essential 错误
帖子发表于 : 2009-04-23 17:16 

注册: 2009-03-05 14:15
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
我在更新source list时候,,,测试美国和中国的服务器,都通不过

然后,,我就选了中国的,,reload就出现错误


附件:
inform.JPG
inform.JPG [ 123.37 KiB | 被浏览 2252 次 ]

页首
 用户资料  
 
6 楼 
 文章标题 : Re: apt-get install build-essential 错误
帖子发表于 : 2009-04-25 10:41 

注册: 2009-01-30 18:18
帖子: 319
地址: 湖北十堰
送出感谢: 5
接收感谢: 3
楼主如果想变成中文就请
系统----系统管理----语言支持里选汉语,然后更新一下。


apt-get install build-essential
这个问题一般是你写错了要安装的软件名字。我使用这种装软件的方法碰到了多次。最典型的是装wine

我开始打apt-get install Wine结果错误
后来换小写apt-get install wine结果就装上了


_________________
愿意同大家一起学习分享linux知识


页首
 用户资料  
 
7 楼 
 文章标题 : Re: apt-get install build-essential 错误
帖子发表于 : 2009-04-25 17:06 

注册: 2009-03-05 14:15
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
楼上,你好,

请问,是不是因为我没有更新软件源呢??


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译