当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请教怎么设置LAMP
帖子发表于 : 2009-10-13 10:03 
头像

注册: 2009-06-11 13:37
帖子: 271
送出感谢: 1
接收感谢: 0 次
昨天刚刚装好linux,用新立得安装了LAMP,一切顺利,浏览器可以浏览127.0.0.1及localhost,当然也可以输入自己的IP。
然后在网上看了下设置自己的站点目录,默认的是在/var/www,但是这里路径对我来说不是很方便,所以想把它改到/home/xxx下。但是改动以后,就不能用了,浏览器输入自己的IP提示:
引用:
Not Found
The requested URL / was not found on this server.
Apache/2.2.11 (Ubuntu) PHP/5.2.6-3ubuntu4.2 with Suhosin-Patch Server at 192.168.1.110 Port 80


请教各位大侠!


_________________
跑debian应该是有点搞头的吧。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 请教怎么设置LAMP
帖子发表于 : 2009-10-13 10:12 
头像

注册: 2007-04-14 11:17
帖子: 1035
送出感谢: 0 次
接收感谢: 2
vi /etc/apache2/sites-available/default

<VirtualHost *:80>
ServerAdmin webmaster@localhost

#下面的几行是自己配置的部分...
# DocumentRoot /var/www
# <Directory />
# Options FollowSymLinks
# AllowOverride None
# </Directory>
DocumentRoot /home/www
<Directory /home/www>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 请教怎么设置LAMP
帖子发表于 : 2009-10-13 10:17 
头像

注册: 2009-06-11 13:37
帖子: 271
送出感谢: 1
接收感谢: 0 次
dwl301 写道:
vi /etc/apache2/sites-available/default

<VirtualHost *:80>
ServerAdmin webmaster@localhost

#下面的几行是自己配置的部分...
# DocumentRoot /var/www
# <Directory />
# Options FollowSymLinks
# AllowOverride None
# </Directory>
DocumentRoot /home/www
<Directory /home/www>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>



我在这个文件里面改了两个“/var/www”,把这个路径改为了/home/xxx(自己的路径) 之后就没有用了

打开的时候不知道在哪看到了提示 找不到DocumentRoot /home/xxx


_________________
跑debian应该是有点搞头的吧。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译