当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : webmin为何不能用https登录呢?
帖子发表于 : 2010-01-08 10:08 

注册: 2009-12-12 22:50
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我的webmin已经安装好了,只能用http:登录,不能用https:登录时提示:
安全连接失败

连接https://192.168.0.182:10000时发生错误。

SSL 接收到一个超出最大准许长度的记录。

(错误码: ssl_error_rx_record_too_long)

我应该怎么做呢?


最后由 gaoyunan2009 编辑于 2010-01-08 18:41,总共编辑了 3 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: webmin为何不能用https登录呢?
帖子发表于 : 2010-01-08 10:33 
头像

注册: 2008-11-05 13:24
帖子: 1024
送出感谢: 0 次
接收感谢: 5
https和ssh有关系吗?


_________________
笔记
-------------------------------------
http://blog.163.com/wqt_1101


页首
 用户资料  
 
3 楼 
 文章标题 : Re: webmin为何不能用https登录呢?
帖子发表于 : 2010-01-08 13:59 

注册: 2009-12-12 22:50
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
如何在Linux上开设使用ssl安全链接的站点
viewtopic.php?f=54&t=243777


页首
 用户资料  
 
4 楼 
 文章标题 : Re: webmin为何不能用https登录呢?
帖子发表于 : 2010-01-08 14:47 
头像

注册: 2008-11-05 13:24
帖子: 1024
送出感谢: 0 次
接收感谢: 5
用的是apache的话,
sudo a2enmod ssl
查看/etc/apache2/port.conf 取消关于ssl的注释
然后对比着default和ssl-default(好象是)写个虚拟主机,比如:
/etc/apache2/sites-available/ssl-webmin 什么key用openssl 生成就行了
sudo a2ensite ssl-webmin 也可以直接修改那个ssl-default,记得备份一个
以https://domain登录试试

有个proxy模块代理挺有意思
<virtualhost *:80>
servername domain
<location />
proxypass http://127.0.0.1:443/
</location>
</virtualhost>


_________________
笔记
-------------------------------------
http://blog.163.com/wqt_1101


页首
 用户资料  
 
5 楼 
 文章标题 : Re: webmin为何不能用https登录呢?
帖子发表于 : 2010-01-08 20:32 

注册: 2009-12-12 22:50
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
Webmin-Webmin配置-SSL加密-Enable SSL if available?点选为“是”,保存后即可使用https登陆


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译