当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ping得通任意域名,但网页打不开,求助...
帖子发表于 : 2006-10-10 17:00 

注册: 2006-03-01 15:18
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
我是电信宽带拨号上网,小区宽带,一根线直接入户接入网卡,再采用和ADSL相同的拨号方式.
静态分配IP,配置PPPOECONF后,PLOG显示已经接通,分配了外网IP,Ping本机IP,DNS,任意域名,如www.baidu.com,都能PING通,LumaQQ也能登陆,但就是FIREFOX打不开任何网页.
新装的系统,排除浏览器问题.
如果是DNS配置的问题,那为什么DNS能PING通呢?
dsl-provider中有一行usepeerdns,这应该是指自动获取DNS吧,我尝试过手动配置,可好像还是不行...
求高手帮助...


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-10-10 18:21 

注册: 2006-03-01 15:18
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
弄了半天,觉得应该还是DNS的问题.
dsl-provider里那一行usepeerdns是自动获取DNS地址,但自动获取的首要DNS却不是本地电信提供的DNS,次要的是正确的,具体原因不知道,可能PPPOECONF跟我这种小区宽带有点那什么,我用FC没出现过这种情况.
而我把usepeerdns注释掉以后,发现拨号后却没有在使用我自己指定的DNS,就是resolv.conf里面那两个...用PLOG查看没有显示任何DNS...是没有指定DNS的状态吧...
请问要如何使拨号后使用上我自己设置的DNS啊,PPPOECONF里面没有手动输入DNS的选项.是否可以直接修改dsl-provider的内容将我的DNS地址写进去呢?如果是,那应该是什么格式啊?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-10-10 19:41 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
引用:
但自动获取的首要DNS却不是本地电信提供的DNS
这种和小区出口设置有关,直接手动设置吧。在/etc/resolv.conf


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-10-11 4:56 

注册: 2006-03-01 15:18
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
谢谢回复~
我是手动设置的, /etc/resolv.conf里是我自己设置的两个DNS,但问题是我把 /etc/ppp/peers/dsl-provider 里的usepeerdns注释掉以后,拨号后并没有使用resolv.conf里的DNS啊.我用PLOG查看也没有显示出DNS地址.若是自动获取的话就会显示出来的.


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-10-11 19:48 

注册: 2006-03-01 15:18
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
是否是PPPOECONF的问题啊?如果换别的拨号软件可不可以?Ubuntu上还有其它的拨号软件可用吗?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-10-12 19:55 

注册: 2006-03-01 15:18
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
有人能告诉我吗?等了一天了...


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-10-21 23:01 

注册: 2006-09-30 21:21
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
我用的不是adsl
是学校的drcom,802.1x+drcom分成的内外网
也是同样的情况,能ping通但是打不开网页


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-07-01 23:28 

注册: 2008-07-01 12:49
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
我同LZ同样的问题,疑惑的很啊。LZ没再继续关注想必是放弃Ubuntu了。。。。。 :oops:


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-07-02 0:26 
头像

注册: 2008-05-15 13:16
帖子: 252
送出感谢: 0 次
接收感谢: 0 次
呵呵 我是河南网通用户 并且网卡还是天煞的8168 差点放弃了


页首
 用户资料  
 
10 楼 
 文章标题 : Re: Ping得通任意域名,但网页打不开,求助...
帖子发表于 : 2008-10-29 11:42 

注册: 2008-06-01 12:31
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
我的也一样,等8.10出了装看看能不能上。不能就不用ub了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译