【求助】ubuntu6.10下装drcom时出错

Web、Mail、Ftp、DNS、Proxy、VPN、Samba、LDAP 等基础网络服务
回复
billy19851
帖子: 46
注册时间: 2006-09-30 21:21
送出感谢: 0
接收感谢: 0

【求助】ubuntu6.10下装drcom时出错

#1

帖子 billy19851 » 2006-10-20 18:41

build-essential与libssl-dev都不能安装,每装一个都会提示要装另一个,可是都说“不会安装”,然后出个依赖提示
不知道有谁安装成功没?
billy19851
帖子: 46
注册时间: 2006-09-30 21:21
送出感谢: 0
接收感谢: 0

#2

帖子 billy19851 » 2006-10-20 23:46

libstdc++6-dev
libstdc++6-dev:
依赖: g++-3.4 但是此软件包将不会被安装
依赖: libc6-dev 但是此软件包将不会被安装
ibc6-dev:
依赖: libc6 (=2.4-1ubuntu10) 但是将会安装 2.4-1ubuntu12
build-essential:
依赖: libc6-dev 但是此软件包将不会被安装 或者
libc-dev
依赖: g++ 但是此软件包将不会被安装
libssl-dev:
依赖: zlib1g-dev 但是此软件包将不会被安装
g++:
依赖: g++-4.1 但是此软件包将不会被安装
g++-4.1:
依赖: gcc-4.1-base (=4.1.1-13ubuntu2) 但是将会安装 4.1.1-13ubuntu3
依赖: gcc-4.1 (=4.1.1-13ubuntu2) 但是将会安装 4.1.1-13ubuntu3
依赖: libstdc++6-4.1-dev 但是此软件包将不会被安装
zlib1g-dev:
依赖: libc6-dev 但是此软件包将不会被安装 或者
libc-dev
billy19851
帖子: 46
注册时间: 2006-09-30 21:21
送出感谢: 0
接收感谢: 0

#3

帖子 billy19851 » 2006-10-21 22:32

build-essential: 依赖: g++ (>= 4:4.1.1) 但是它将不会被安装
build-essential是首要要解决的问题
g++又依赖g++-4.1
g++-4.1又依赖gcc-4.1-base (=4.1.1-13ubuntu2),可是6.10里里面好像是gcc-4.1-base (=4.1.1-13ubuntu3),我也试着把3换成2的,但是得来的结果是一连串的依赖破坏,郁闷之极
在6.10下,大家都是用什么替代build-essential?
tthq
帖子: 2
注册时间: 2007-03-20 14:46
送出感谢: 0
接收感谢: 0

#4

帖子 tthq » 2007-03-20 14:49

me too 我问题也是阿 哪位大虾来救阿
nonsensor
帖子: 1
注册时间: 2008-06-01 6:28
送出感谢: 0
接收感谢: 0

#5

帖子 nonsensor » 2008-06-01 6:30

我也遇到了相同的问题 后来通过更新源解决了
更新源的网页在此:
http://wiki.ubuntu.org.cn/%E5%A6%82%E4% ... 4%E6%BA%90

希望有所帮助
pengchy
帖子: 37
注册时间: 2008-07-13 12:51
送出感谢: 0
接收感谢: 0
联系:

Re: 【求助】ubuntu6.10下装drcom时出错

#6

帖子 pengchy » 2008-10-09 21:29

谢谢楼上!!问题解决了
回复

回到 “服务器基础应用”