当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu 10.04 LTS安装后字符界面显示乱码
帖子发表于 : 2010-06-16 11:38 

注册: 2010-05-18 9:34
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我安装的是Ubuntu 10.04 LTS安装完后我想装一个bind9 可是大部分信息显示乱码 应该怎么解决呢


附件:
乱码截图.png
乱码截图.png [ 4.97 KiB | 被浏览 1446 次 ]
页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu 10.04 LTS安装后字符界面显示乱码
帖子发表于 : 2010-06-16 11:39 
头像

注册: 2008-11-05 13:24
帖子: 1024
送出感谢: 0 次
接收感谢: 5
换成英文环境


_________________
笔记
-------------------------------------
http://blog.163.com/wqt_1101


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu 10.04 LTS安装后字符界面显示乱码
帖子发表于 : 2010-06-16 11:41 
头像

注册: 2008-03-25 15:49
帖子: 25878
地址: 谁知道?
送出感谢: 8
接收感谢: 10
重新设置个英文 locale.


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Ubuntu 10.04 LTS安装后字符界面显示乱码
帖子发表于 : 2010-06-16 12:05 

注册: 2010-05-18 9:34
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
可不可以具体一点呢 刚刚用Ubuntu不久 我没有装GNOME只有字符界面应该怎么操作呢


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Ubuntu 10.04 LTS安装后字符界面显示乱码
帖子发表于 : 2010-06-16 12:10 
头像

注册: 2008-03-25 15:49
帖子: 25878
地址: 谁知道?
送出感谢: 8
接收感谢: 10
jack_guo 写道:
可不可以具体一点呢 刚刚用Ubuntu不久 我没有装GNOME只有字符界面应该怎么操作呢

小麻烦. ubuntu跟debian的不大一样.
locale-gen 搜搜


页首
 用户资料  
 
6 楼 
 文章标题 : Re: Ubuntu 10.04 LTS安装后字符界面显示乱码
帖子发表于 : 2010-06-16 12:13 

注册: 2010-05-18 9:34
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
:em06


页首
 用户资料  
 
7 楼 
 文章标题 : Re: Ubuntu 10.04 LTS安装后字符界面显示乱码
帖子发表于 : 2010-06-16 12:14 
头像

注册: 2008-03-25 15:49
帖子: 25878
地址: 谁知道?
送出感谢: 8
接收感谢: 10
:em06


页首
 用户资料  
 
8 楼 
 文章标题 : Re: Ubuntu 10.04 LTS安装后字符界面显示乱码
帖子发表于 : 2010-06-16 15:01 

注册: 2010-05-18 9:34
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
搞了半天locale-gen也没弄好 :em06 最后用
export LANG=en_US
export LC_ALL=en_US
解决了 :em09


页首
 用户资料  
 
9 楼 
 文章标题 : Re: Ubuntu 10.04 LTS安装后字符界面显示乱码
帖子发表于 : 2010-06-16 15:31 
头像

注册: 2008-09-06 5:11
帖子: 363
地址: 石家庄
送出感谢: 1
接收感谢: 8
server版的?


_________________
http://phpcj.org/
河北Linux用户组QQ群:249872047
Gentoo中文社区QQ群:160294591


页首
 用户资料  
 
10 楼 
 文章标题 : Re: Ubuntu 10.04 LTS安装后字符界面显示乱码
帖子发表于 : 2010-06-16 16:54 

注册: 2010-05-18 9:34
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
是的


页首
 用户资料  
 
11 楼 
 文章标题 : Re: Ubuntu 10.04 LTS安装后字符界面显示乱码
帖子发表于 : 2010-08-04 16:08 

注册: 2010-08-04 16:00
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
可以试下安装 sudo apt-get install zhcon
然后 zhcon --utf8
这样就显示中文了


PS:安装Ubuntu 10.04时,语言要选择中文。如果选了英文的话,装了zhcon也还是乱码。


页首
 用户资料  
 
12 楼 
 文章标题 : Re: Ubuntu 10.04 LTS安装后字符界面显示乱码
帖子发表于 : 2010-08-05 17:09 

注册: 2010-02-22 15:01
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
楼主谢了,我的也出现类似的问题,用你的命令解决了,就是不知道这条命令是什么意思,应该界面下也能实现,但是试了下好像不行!!
:em02


页首
 用户资料  
 
13 楼 
 文章标题 : Re: Ubuntu 10.04 LTS安装后字符界面显示乱码
帖子发表于 : 2011-03-27 15:47 
头像

注册: 2010-08-27 15:49
帖子: 55
地址: bashman@yahoo.cn
送出感谢: 0 次
接收感谢: 0 次
呵呵,对诶,我弄LFS也是,现在只有字符界面,准备安装一个图形界面。 :em06


_________________
在linux的路上跋涉。 云端的生活。

在学习的路途上,我永远是一个菜鸟。。。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译