当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : evolution用不了
帖子发表于 : 2006-10-23 23:20 

注册: 2006-04-24 20:29
帖子: 83
送出感谢: 0 次
接收感谢: 0 次
打开老是不响应,又不自动关闭。死住了。
用APT升级一下吧,下了几十M的依赖包,其中涉及到内核的一个东西,我不敢升级,跳过。升级完了还是不行。
现在的问题是,删除也删不了,出现了依赖问题。
代码:
route@wpro:~$ sudo apt-get remove evolution
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
  evolution-exchange: 依赖: evolution (>= 2.4.1) 但是它将不会被安装
  evolution-plugins: 依赖: evolution (= 2.4.1-0ubuntu7) 但是它将不会被安装
                     依赖: evolution (>= 2.4.1) 但是它将不会被安装
  linux-image-2.6.12-10-686: 依赖: initramfs-tools (>= 0.17) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
route@wpro:~$ sudo apt-get -f remove evolution
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
  evolution-exchange: 依赖: evolution (>= 2.4.1) 但是它将不会被安装
  evolution-plugins: 依赖: evolution (= 2.4.1-0ubuntu7) 但是它将不会被安装
                     依赖: evolution (>= 2.4.1) 但是它将不会被安装
  linux-image-2.6.12-10-686: 依赖: initramfs-tools (>= 0.17) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
route@wpro:~$ sudo apt-get -f install evolution
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
  evolution: 依赖: libavahi-client3 (>= 0.6.0) 但是它将不会被安装
             依赖: libavahi-common3 (>= 0.6.9) 但是它将不会被安装
             依赖: libavahi-glib1 (>= 0.6.0) 但是它将不会被安装
             依赖: libbonobo2-0 (>= 2.13.0) 但是 2.10.1-0ubuntu1 正要被安装
             依赖: libcamel1.2-8 (>= 1.6.1) 但是它将不会被安装
             依赖: libdbus-1-2 (>= 0.60) 但是它将不会被安装
             依赖: libdbus-glib-1-2 (>= 0.60) 但是它将不会被安装
             依赖: libebook1.2-5 (>= 1.6.1) 但是 1.4.1-0ubuntu3 正要被安装
             依赖: libecal1.2-3 (>= 1.6.1) 但是 1.4.1-0ubuntu3 正要被安装
             依赖: libedataserver1.2-7 (>= 1.6.1) 但是它将不会被安装
             依赖: libedataserverui1.2-6 (>= 1.6.1) 但是 1.4.1-0ubuntu3 正要被安装
             依赖: libgconf2-4 (>= 2.13.5) 但是 2.12.0-0ubuntu1 正要被安装
             依赖: libgnomeui-0 (>= 2.13.0) 但是 2.12.0-0ubuntu1 正要被安装
             依赖: libgnomevfs2-0 (>= 2.13.92-0ubuntu4) 但是 2.12.1-0ubuntu2 正 要被安装
             依赖: libgtkhtml3.8-15 (>= 3.10.1) 但是 3.8.1-0ubuntu1 正要被安装
             依赖: libnotify1 但是它将不会被安装
             依赖: libsoup2.2-8 (>= 2.2.92) 但是 2.2.6.1-0ubuntu1 正要被安装
             依赖: gconf2 (>= 2.12.1-4ubuntu1) 但是 2.12.0-0ubuntu1 正要被安装
             依赖: evolution-data-server (>= 1.5.5) 但是 1.4.1-0ubuntu3 正要被安装
  evolution-plugins: 依赖: evolution (= 2.4.1-0ubuntu7) 但是 2.6.1-0ubuntu7 正要被安装
  linux-image-2.6.12-10-686: 依赖: initramfs-tools (>= 0.17) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-11-06 15:49 

注册: 2006-09-11 14:48
帖子: 35
送出感谢: 0 次
接收感谢: 0 次
有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)

直接运行apt-get -f install或许能解决问题


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译