当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [help]软件包无法被安装。如果您用的是不稳定(unstable)发行版,因为系统无法达到您要求的状态造成的
帖子发表于 : 2010-08-28 15:06 

注册: 2006-09-10 13:18
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
gaston@ubuntu:~/tmp$ sudo apt-get install php5-mysql
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
php5-mysql: 依赖: php5-common (= 5.2.10.dfsg.1-2ubuntu6) 但是 5.2.10.dfsg.1-2ubuntu6.4 正要被安装
E: 无法安装的软件包

---->装gd也是一样..
下列的软件包有不能满足的依赖关系:
php5-gd: 依赖: php5-common (= 5.2.10.dfsg.1-2ubuntu6) 但是 5.2.10.dfsg.1-2ubuntu6.4 正要被安装
E: 无法安装的软件包


求解...感谢!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: [help]软件包无法被安装。如果您用的是不稳定(unstable)发行版,因为系统无法达到您要求的状态造成的
帖子发表于 : 2015-02-07 9:48 

注册: 2015-01-15 18:02
帖子: 46
系统: ubuntu 10.04
送出感谢: 0 次
接收感谢: 0 次
同问,我也是碰到这个问题,我是将ubuntu自带的php5.3降为5.2后,再用apt-get -t karmic install php5-gd 安装就提示这个错误了
php5-gd: Depends: php5-common (= 5.2.10.dfsg.1-2ubuntu6.10) but 5.2.10.dfsg.1-2ubuntu6 is to be installed

楼主这个问题在2006年就提出了,难道现在还没有人能解吗? :em20


页首
 用户资料  
 
3 楼 
 文章标题 : Re: [help]软件包无法被安装。如果您用的是不稳定(unstable)发行版,因为系统无法达到您要求的状态造成的
帖子发表于 : 2015-02-07 11:10 

注册: 2015-01-15 18:02
帖子: 46
系统: ubuntu 10.04
送出感谢: 0 次
接收感谢: 0 次
擦,最终从网上下载deb来安装,搞了一大堆的关联包,累死了

https://launchpad.net/ubuntu/karmic/i38 ... 1-2ubuntu6


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译