当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请教 10.04 LAMP-server apache2问题
帖子发表于 : 2010-10-15 1:28 

注册: 2010-03-02 14:21
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
先介绍一下我的情况:
1网络:我的服务器是在内网的 所以内网IP 通过路由映射80做WEB
2服务器版本 Ubuntu 10.04 LTS Server_i386
3LAMP环境是通过Ubuntu Tasksel install LAMP-server 安装的 【因为懒得去编译修改了】
4LAMP版本 apache2.2.4 php5.3.2
5IP地址 192.168.3.123
问题:我以前用的是 8.04 LTS 配置apache 基于域名的虚拟主机 NameVirtualHost 只出现一次 其余主机没有 NameVirtualHost 只设置 <VirtualHost>
配置如下:
default 主机
代码:
NameVirtualHost 192.168.3.33
<VirtualHost 192.168.3.33>
   ServerAdmin webmaster@localhost.com
   DocumentRoot /home/wwwroot/   
                ServerName 192.168.3.33
   <Directory />
      Options FollowSymLinks
      AllowOverride All
   </Directory>
   <Directory /home/wwwroot/>
      Options -Indexes FollowSymLinks MultiViews
      AllowOverride All
      Order allow,deny
      allow from all
   </Directory>

   ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
   <Directory "/usr/lib/cgi-bin">
      AllowOverride None
      Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
      Order allow,deny
      Allow from all
   </Directory>

   ErrorLog /home/wwwroot/log/default/error.log

   # Possible values include: debug, info, notice, warn, error, crit,
   # alert, emerg.
   LogLevel warn

   CustomLog /home/wwwroot/log/default/access.log combined
   ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>


第二是其他域名主机的配置
代码:
        <VirtualHost 192.168.3.33>
                ServerAdmin AlanSun.17@sohu.com

   DocumentRoot /home/wwwroot/eno8.cn/
        ServerAlias www.eno8.cn eno8.cn
        ServerName eno8.cn
   <Directory />
      Options FollowSymLinks
      AllowOverride All
   </Directory>
   <Directory /home/wwwroot/eno8.cn>
      Options -Indexes FollowSymLinks MultiViews
      AllowOverride All
      Order allow,deny
      allow from all
   </Directory>

   ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
   <Directory "/usr/lib/cgi-bin">
      AllowOverride None
      Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
      Order allow,deny
      Allow from all
   </Directory>

   ErrorLog /home/wwwroot/log/eno8/error.log

   # Possible values include: debug, info, notice, warn, error, crit,
   # alert, emerg.
   LogLevel warn

   CustomLog /home/wwwroot/log/eno8/access.log combined
   ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

# #Domian Jump
RewriteEngine on
RewriteMap lowercase int:tolower
RewriteMap vhost txt:/etc/apache2/vhost.map
RewriteCond ${lowercase:%{SERVER_NAME}} ^(.+)$
RewriteCond ${vhost:%1} ^(/.*)$
RewriteRule ^/(.*)$ %1/$1

</VirtualHost>



子域名绑定目录使用的是 vhost.map 进行跳转的。

问题是现在 我用 10.04 安装的 LAMP环境 按照以上配置总是 报错 我个人认为应该是 apache版本提升后有了新的改动
所以导致以前的设置不能用了
下面给出我的日志 麻烦了解的朋友帮我解决一下这个问题。很棘手.在这里很感谢、

错误日志:
代码:
[Fri Oct 15 01:08:37 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
[Fri Oct 15 01:08:37 2010] [warn] NameVirtualHost *:80 has no VirtualHosts

[Fri Oct 15 01:05:13 2010] [warn] VirtualHost 192.168.3.123:80 overlaps with VirtualHost 192.168.3.123:80, the first has precedence, perhaps you need a NameVirtualHost directive


请问要设置基于域名的虚拟主机应该如何设置???


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译