当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 禁止目录浏览,在default设置了没有用。
帖子发表于 : 2010-12-17 16:16 

注册: 2010-08-18 14:47
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
在default里:
找到了。
<Directory /var/www/>
Options -Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all
</Directory>
对这行:
Options -Indexes FollowSymLinks MultiViews
改了,在indexes前面加了一横,可是还是可以浏览目录。为什么呢?


:em03


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 禁止目录浏览,在default设置了没有用。
帖子发表于 : 2010-12-17 18:17 
头像

注册: 2010-08-27 15:53
帖子: 803
送出感谢: 0 次
接收感谢: 1
Options FollowSymLinks MultiViews


_________________
基础问题,请看入门手册http://people.ubuntu.com/~happyaron/udc-cn/lucid-html/

Acer aspire 4736G / Ubuntu 10.04LTS
Asus eeepc900 / Xandros
Nokia N900 / Maemo 1.2.12


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 禁止目录浏览,在default设置了没有用。
帖子发表于 : 2010-12-20 16:14 

注册: 2010-08-18 14:47
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
这样也不可以的,只有把这行放到相关的主机定义里才行,这比win里烦点。
可能我哪里没有掌握。先这样弄好了。

<VirtualHost 184.82.101.90:80>
ServerName a.aaa.com
ServerAdmin admin@w.com
DocumentRoot "/var/www/a/a"
ErrorLog "/var/log/apache2/errors.log"
CustomLog "/var/log/apache2/accesses.log" common
Options FollowSymLinks
</VirtualHost>


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 禁止目录浏览,在default设置了没有用。
帖子发表于 : 2010-12-21 18:40 

注册: 2010-11-21 16:00
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
把 indexes 删掉就可以了,我和你添加虚拟主机的方法不一样 我的 httpd.conf 配置文件时空的。我实在 sites-available 文件夹里面添加的配置文件, 每个网站一个配置文件 方便管理,


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译