ubuntu怎么安装php5.2 默认的是php5.3 不知吃zend optmizer

Web、Mail、Ftp、DNS、Proxy、VPN、Samba、LDAP 等基础网络服务
回复
qijun4588
帖子: 2
注册时间: 2011-01-01 11:55
送出感谢: 0
接收感谢: 0

ubuntu怎么安装php5.2 默认的是php5.3 不知吃zend optmizer

#1

帖子 qijun4588 » 2011-01-01 13:32

百度一下,说在preferences.d建立个php文件的方法试了 不太给力
oceanwave
帖子: 169
注册时间: 2007-04-02 21:40
送出感谢: 0
接收感谢: 0

Re: ubuntu怎么安装php5.2 默认的是php5.3 不知吃zend optmizer

#2

帖子 oceanwave » 2011-01-04 15:26

要想支持zend,有2个方案
1. 将php5.3.* 降级到 php5.2.*
-------(降级非常方便,网上有现成的脚本及说明)
2. 不使用zend optimizer,改成使用新版的zend Guard Loader
-------(只支持新版zend加密过的php程序)

但是,但是,若您的php程序是经过旧版zend(5.2.*)加密过的程序,则
1. 只能使用第1种方案.
2. 找到php程序开发商,取得解密后的php代码,重新使用新版zend加密,然后在php5.3上搭配zend guard loader来使用.
------(这条可行性不大,比如supesite 6.*,开发商基本不太可能重新用新版zend重新加密,然后再重复发布一下.)
回复

回到 “服务器基础应用”