升级nginx 出现如下错误!?

Web、Mail、Ftp、DNS、Proxy、VPN、Samba、LDAP 等基础网络服务
回复
nebidun
帖子: 1
注册时间: 2011-05-05 21:53
送出感谢: 0
接收感谢: 0

升级nginx 出现如下错误!?

#1

帖子 nebidun » 2011-05-18 15:08

之前升级nginx 时,出现了www不为空等错误后就退出了,现在只要apt-get install 任何东西就会出现要我执行apt-get -f install;
服务器端打开更新管理器更新系统提示
软件包系统已损坏,要我禁用第三方源后在终端执行 apt-get -f install;

执行后出现如下错误!请问如何解决,如何修复损坏的软件包?

代码: 全选

root@basbas:~# apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
  nginx-common
下列【新】软件包将被安装:
  nginx-common
升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 2 个软件包未被升级。
有 2 个软件包没有被完全安装或卸载。
需要下载 0B/59.6kB 的软件包。
解压缩后会消耗掉 246kB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前共安装有 174461 个文件和目录。)
正在解压缩 nginx-common (从 .../nginx-common_1.0.2-0ppa1~maverick_all.deb) ...
dpkg:处理 /var/cache/apt/archives/nginx-common_1.0.2-0ppa1~maverick_all.deb (--unpack)时出错:
 正试图覆盖“/etc/ufw/applications.d/nginx”,它同时被包含于软件包 nginx 1.0.2-0ppa1~maverick
由于已经达到 MaxReports 限制,没有写入 apport 报告。
                                                    正在处理用于 man-db 的触发器...
正在处理用于 ureadahead 的触发器...
ureadahead will be reprofiled on next reboot
正在处理用于 ufw 的触发器...
在处理时有错误发生:
 /var/cache/apt/archives/nginx-common_1.0.2-0ppa1~maverick_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

回复

回到 “服务器基础应用”