当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : nat网络共享的一个问题
帖子发表于 : 2006-12-15 12:31 

注册: 2005-10-07 9:22
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
用iptables设置 internet网络共享nat的时候,首先需要开启系统的ip转发功能,也就是需要把/proc/sys/net/ipv4/ip_foward文件中的0改为1,但我在该这个文件的时候,vi报错(sudo执行vi):
WARNING: The file has been changed since reading it!!!
Do you really want to write to it (y/n)?
输入y后,显示
"ip_forward" E667: Fsync failed
Hit ENTER or type command to continue

也就是这个文件的内容改不了,这是怎么回事阿?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-12-15 23:13 
头像

注册: 2005-10-23 11:56
帖子: 110
送出感谢: 0 次
接收感谢: 0 次
在6.06或6.10中没有这个命令的。不知道怎么做。shorewall也没做成。


_________________
我是神仙,想睡觉,我要睡觉似神仙
MSN :pdsjj@21cn.com
QQ:280367891
ICQ:381167891

Acer aspire one D250(1284) for ubuntu


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-12-20 18:10 

注册: 2006-10-10 11:01
帖子: 147
送出感谢: 0 次
接收感谢: 0 次
my@my-desktop:/proc/sys/net/ipv4$ ls -l ip_forward
-rw-r--r-- 1 root root 0 2006-12-20 18:07 ip_forward
my@my-desktop:/proc/sys/net/ipv4$ sudo echo "1" > ip_forward
bash: ip_forward: Permission denied

是呀,超级奇怪呀,为什么直接echo都不行?我在redhat上从来 都这样搞没问题的呀?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-12-20 18:16 

注册: 2006-10-10 11:01
帖子: 147
送出感谢: 0 次
接收感谢: 0 次
找到办法了,就在论坛上,

实际上在
sudo echo 1 > /proc/sys/net/ipv4/ip_forward
只有echo1部分是用root运行
"> file" 这个还是由原来的用户运行,所以权限还是不行
换成这样看看
echo 1|sudo tee /proc/sys/net/ipv4/ip_forward

不过不知道在启动脚本的有没有问题,应该没有吧,服务都是root吧


页首
 用户资料  
 
5 楼 
 文章标题 : Re: nat网络共享的一个问题
帖子发表于 : 2009-07-01 13:22 

注册: 2009-07-01 13:21
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
不要直接修改 /proc/sys/net/ipv4/ip_forward

应该改/etc/sysctl.conf

# Uncomment the next line to enable packet forwarding for IPv4
net.ipv4.ip_forward=1


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译