安裝samba出錯

Web、Mail、Ftp、DNS、Proxy、VPN、Samba、LDAP 等基础网络服务
回复
jofo
帖子: 1
注册时间: 2012-12-08 20:58
送出感谢: 0
接收感谢: 0

安裝samba出錯

#1

帖子 jofo » 2013-02-13 16:41

錯誤如下:


sam@PC01-Ubuntu:~$ sudo apt-get install samba samba-common
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
samba-common 已经是最新的版本了。
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
samba : 依赖: samba-common (= 2:3.6.3-2ubuntu2.1) 但是 2:3.6.3-2ubuntu2.3 正要被安装
依赖: libwbclient0 (= 2:3.6.3-2ubuntu2.1) 但是 2:3.6.3-2ubuntu2.3 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

sam@PC01-Ubuntu:~$ sudo apt-get install samba
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
samba : 依赖: samba-common (= 2:3.6.3-2ubuntu2.1) 但是 2:3.6.3-2ubuntu2.3 正要被安装
依赖: libwbclient0 (= 2:3.6.3-2ubuntu2.1) 但是 2:3.6.3-2ubuntu2.3 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
头像
mraandtux
论坛版主
帖子: 5110
注册时间: 2009-12-12 19:29
系统: Ubuntu + Windows 10
来自: 随便一个地方
送出感谢: 0
接收感谢: 161 次
联系:

Re: 安裝samba出錯

#2

帖子 mraandtux » 2013-02-13 17:03

换源或者用新力得安装。
头像
AutoXBC
帖子: 1744
注册时间: 2007-10-23 12:54
送出感谢: 2 次
接收感谢: 24 次

Re: 安裝samba出錯

#3

帖子 AutoXBC » 2013-02-13 19:06

先删掉 samba 和 samba-common,然后刷新源 update,再次安装 samba 就可以了。另外注意不要去指定安装 samba-common,这个包是 samba 的依赖,显式指定属于画蛇添足。
回复

回到 “服务器基础应用”