当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]校园网认证成功却不能上网?
帖子发表于 : 2007-03-11 14:28 

注册: 2007-03-07 4:16
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
我是用superstar来认证校园网的,我们学校很多人都用这个,都没问题,但我那里却用不了。刚运行完那个程序后,可以上十几秒钟,右上角那个联网的图标开始转动。十多秒后,那个图标不转了,也上不了网了。请问这是为什么?是不是我有什么东西没装,或者配置有问题?我的是从硬盘默认安装的,因为上不了网,所以有很多程序都没装。

运行完那个程序后显示这个,应该是认证成功了吧:
锟斤拷迎锟斤拷锟斤拷锟戒汉锟斤拷学校园锟?Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth1/00:20:ed:1e:c1:b4
Sending on LPF/eth1/00:20:ed:1e:c1:b4
Sending on Socket/fallback
DHCPRELEASE on eth1 to 10.20.0.1 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth1/00:20:ed:1e:c1:b4
Sending on LPF/eth1/00:20:ed:1e:c1:b4
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 6
DHCPOFFER from 222.20.232.254
DHCPREQUEST on eth1 to 255.255.255.255 port 67
DHCPACK from 222.20.232.254
SIOCADDRT: File exists
bound to 222.20.232.226 -- renewal in 1217 seconds.


但是查看网卡的信息,却显示:
ifconfig eth1
eth1 Link encap:Ethernet HWaddr 00:20:ED:1E:C1:B4
inet addr:169.254.52.49 Bcast:169.254.255.255 Mask:255.255.0.0
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:298 errors:0 dropped:0 overruns:0 frame:0
TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:22898 (22.3 KiB) TX bytes:11984 (11.7 KiB)


和DHCP服务器返回的地址不同


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-03-11 14:30 

注册: 2007-03-07 4:16
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
ps:我是刚开始学linux,所以有些东西说得可能不清晰,请大家尽量提出,我会改正的


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-03-13 1:44 

注册: 2007-03-07 4:16
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
怎么,没有人来帮助下我吗?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-03-15 10:20 
头像

注册: 2007-03-07 9:35
帖子: 198
送出感谢: 0 次
接收感谢: 0 次
DNS正确不?先PING一下网关,如果能上就看看DNS.


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-03-17 14:17 

注册: 2006-12-31 20:21
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我也出现过这种情况,我不得又装了WINDOWS XP,用了学校的上网软件能上网,我再查一下ip,发现学校把我们宿舍的ip改了。我以回到UBUNTU,把ip改成与XP里的一致,就一切OK了


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-03-18 2:26 

注册: 2007-03-07 4:16
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
sumwin 写道:
我也出现过这种情况,我不得又装了WINDOWS XP,用了学校的上网软件能上网,我再查一下ip,发现学校把我们宿舍的ip改了。我以回到UBUNTU,把ip改成与XP里的一致,就一切OK了


我们学校用的是DHCP啊,不是静态IP的


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-03-18 2:28 

注册: 2007-03-07 4:16
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
prettysnail 写道:
DNS正确不?先PING一下网关,如果能上就看看DNS.


我曾经这样试过,不断的ping一个地址,发现前面的那些可以ping通,到了后面就不行了,重新认证后,又是这样


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-03-18 14:33 

注册: 2006-09-21 0:37
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
我也是superstar上网,一直以来都很好啊看了
看了一下你贴的内容发现
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
是我的中没有的。
并且你也没有认证成功,因为成功后最下面一行应该是"success!!"
看起来似乎是网卡设置不对。你是不是有两块网卡,一般默认的网卡是eth0,而你的是eth1。
我用命令ifconfig 得到的ip与认证的ip一致。可能是你的两块网卡设置冲突了吧


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译