[问题]ubuntu6.10 下面编译xbnbt出错

Web、Mail、Ftp、DNS、Proxy、VPN、Samba、LDAP 等基础网络服务
回复
axing
帖子: 1
注册时间: 2007-03-13 0:41
送出感谢: 0
接收感谢: 0

[问题]ubuntu6.10 下面编译xbnbt出错

#1

帖子 axing » 2007-03-13 0:44

我在ubuntu下面编译bnbt出现如下错误:

bnbt_mysql.h:36: error: expected ‘;’ before ‘*’ token
bnbt.cpp: In function ‘int bnbtmain()’:
bnbt.cpp:684: error: ‘gpMySQL’ was not declared in this scope
bnbt.cpp:684: error: ‘mysql_init’ was not declared in this scope
bnbt.cpp:686: error: ‘mysql_error’ was not declared in this scope
bnbt.cpp:731: error: ‘gpMySQL’ was not declared in this scope
bnbt.cpp:731: error: ‘mysql_real_connect’ was not declared in this scope
bnbt.cpp:733: error: ‘mysql_error’ was not declared in this scope
bnbt.cpp:776: error: ‘gpMySQL’ was not declared in this scope
bnbt.cpp:776: error: ‘mysql_select_db’ was not declared in this scope
bnbt.cpp:778: error: ‘mysql_error’ was not declared in this scope
bnbt.cpp:1037: error: ‘gpMySQL’ was not declared in this scope
bnbt.cpp:1042: error: ‘mysql_close’ was not declared in this scope
make: *** [bnbt.mysql.o] Error 1

mysql 已经用apt-get 安装好运行了
我google 了一下 说是缺少mysql 类库
请达人给个解决方法
回复

回到 “服务器基础应用”