[问题] 怎样通过 Samba 共享 Windows 系统的文件 (已解决)

Web、Mail、Ftp、DNS、Proxy、VPN、Samba、LDAP 等基础网络服务
回复
头像
mg12
帖子: 49
注册时间: 2007-01-26 21:20
来自: 中国广东
送出感谢: 0
接收感谢: 0
联系:

[问题] 怎样通过 Samba 共享 Windows 系统的文件 (已解决)

#1

帖子 mg12 » 2007-04-21 9:41

已经通过修改 /etc/fstab 挂载了 Windows 的盘, 例如: 将 E: 盘挂在 /windows/e.
测试过 Samba 已经能正常工作.
在 /etc/samba/smb.conf 添加一段文字, 如下:

代码: 全选

[Music]
comment = Music
path = /windows/e/Music
public = yes
available = no
browsable = no
writable = no


在网络里面看 Music 这个文件夹, 打开却什么内容都没有.
以前我用 Fedora 通过以上方法是可以的, 初用 Ubuntu, 很多不明白, 还请指教.
P.S. 我用的是 Ubuntu 7.04.

--------------------------------------------------------------------------------------------

解决办法:
要允许普通用户对挂载的 Windows 分区(FAT、FAT32 或 NTFS)的访问,您得将可选项
umask=0
添加到‘/etc/fstab’的相应条目中,然后重新挂载该分区。没有这个可选项的话,只有‘root’可以访问那个分区。
上次由 mg12 在 2007-04-28 15:27,总共编辑 1 次。
头像
mg12
帖子: 49
注册时间: 2007-01-26 21:20
来自: 中国广东
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 mg12 » 2007-04-21 20:07

补个图. 打开这些文件夹会这样显示.
附件
Screenshot-nautilus.png
Screenshot-nautilus.png (6.79 KiB) 查看 1731 次
Laura
帖子: 8
注册时间: 2007-03-23 16:58
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 Laura » 2007-04-21 23:30

挂载的时候,在<options> 下加上iocharset=utf8 试试。。。
kinuxer
帖子: 1
注册时间: 2007-08-16 20:11
送出感谢: 0
接收感谢: 0

#4

帖子 kinuxer » 2007-08-16 22:07

跟我的问题一样,烦恼中! :shock:
elinkyou
帖子: 10
注册时间: 2007-12-15 18:24
送出感谢: 0
接收感谢: 0

#5

帖子 elinkyou » 2007-12-22 12:03

我的也有类似情况,不过我的ntfs的分区是正常的!
头像
china_baby
帖子: 71
注册时间: 2007-06-20 13:17
来自: 上海
送出感谢: 0
接收感谢: 0

#6

帖子 china_baby » 2007-12-27 15:33

available = no
browsable = no
??
是否我,真的一无所有??
头像
wwdlyx
帖子: 85
注册时间: 2006-11-20 17:26
来自: 福建厦门
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 wwdlyx » 2007-12-28 10:07

如果已经解决就应该把方法补完整。谢谢!
欢迎访问我的qzone
http://21351142.qzone.qq.com
欢迎访问我的blog
http://wuwd.blog.ubuntu.org.cn
回复

回到 “服务器基础应用”