无法apt-get install 了

Web、Mail、Ftp、DNS、Proxy、VPN、Samba、LDAP 等基础网络服务
回复
aminiboy
帖子: 10
注册时间: 2005-09-26 23:54
送出感谢: 0
接收感谢: 0

无法apt-get install 了

#1

帖子 aminiboy » 2005-10-28 4:18

系统是Ubuntu-server,因为某些原因,数次反覆安装卸载proftpd,后来不知道什么原因不能再安装proftpd了,甚至最后要求apt-get install -f 来修复问题,但始终要求安装proftpd,却不能安装,不能用apt-get install 了:

正在解压缩 proftpd-mysql (从 .../proftpd-mysql_1.2.10-22_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/proftpd-mysql_1.2.10-22_i386.deb (--unpack)时出错:
正试图覆盖“/usr/sbin/proftpd”,它属于软件包 psa-proftpd
dpkg-deb: 子进程 paste 被信号(断开的管道)终止了
在处理时有错误发生:
/var/cache/apt/archives/proftpd-common_1.2.10-22_i386.deb
/var/cache/apt/archives/proftpd-mysql_1.2.10-22_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@ubuntu:/down#
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2005-10-28 17:24

dpkg-deb: 子进程 paste 被信号(断开的管道)终止了
碰过几次,注销或者升级可能可以解决。反正不知道原理。
● 鸣学
aminiboy
帖子: 10
注册时间: 2005-09-26 23:54
送出感谢: 0
接收感谢: 0

#3

帖子 aminiboy » 2005-10-31 15:24

有能解决的么?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2005-11-03 22:36

依赖关系可能乱了。新利得里面刷新,看有什么提示。比如几个包broken之类的。有提示的包,可以dpkg -s看一下。
● 鸣学
回复

回到 “服务器基础应用”