[问题]apt-get 失效问题 (大多提示的命令都已经试过 还是不行 请指教)

Web、Mail、Ftp、DNS、Proxy、VPN、Samba、LDAP 等基础网络服务
回复
godencrystal
帖子: 86
注册时间: 2007-07-17 21:48
来自: SJTU
送出感谢: 0
接收感谢: 0

[问题]apt-get 失效问题 (大多提示的命令都已经试过 还是不行 请指教)

#1

帖子 godencrystal » 2007-08-07 18:40

下载并安装一个软件不成功,便出现一下错误
becker@becker-laptop:~$ sudo apt-get autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
compiz: Depends: compiz-decorator
compiz-gnome: Depends: compiz-gtk (= 1:0.3.6-1ubuntu13) but it is not installed
E: Unmet dependencies. Try using -f.
而我 apt-get -f ; apt-get clean ; apt-get remove 等命令都试过 还是不可以:( 请指教
附件
Screenshot.png
头像
sevk
帖子: 2059
注册时间: 2007-05-08 16:26
系统: arch
来自: 火星内核某分子内某原子核内
送出感谢: 19 次
接收感谢: 6 次
联系:

#2

帖子 sevk » 2007-08-07 21:54

换源,清空非官方源试试
笔记本 :
F208S : gentoo
A460P i3G D6 : UBUNTU + WIN7
UN43D1 : UBUNTU + WIN7
1000人超级QQ群 LINUX + WIN : 31465544 或 18210387
头像
bobo4548
帖子: 661
注册时间: 2007-07-17 22:52
来自: cn,shandong
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 bobo4548 » 2007-08-09 6:57

LZ问题解决了吗???另外你输入的命令也不对啊应是apt-get -f install 才行啊
fatalerr
帖子: 49
注册时间: 2007-09-06 17:54
送出感谢: 0
接收感谢: 0

#4

帖子 fatalerr » 2007-11-28 8:55

我也遇到同样的问题了,并且我在执行apt-get -f install的时候,系统提示我要删除一大堆东西,问我是否继续,我害怕,cancel掉了。:(
junl@szsrv01:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
libc6-dev: Depends: libc6 (= 2.3.6-0ubuntu20.5) but 2.5-0ubuntu14 is installed
libc6-i686: PreDepends: libc6 (= 2.3.6-0ubuntu20.5) but 2.5-0ubuntu14 is installed
libgcc1: Depends: gcc-4.1-base (= 4.1.2-0ubuntu4) but it is not installable
E: Unmet dependencies. Try using -f.
junl@szsrv01:~$
junl@szsrv01:~$
junl@szsrv01:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... Done
The following packages will be REMOVED:
apache2 apache2-common apache2-mpm-prefork apt apt-utils aptitude build-essential dselect
g++ g++-4.0 gcc gcc-4.0 groff-base libapache2-mod-php5 libc6-dev libc6-i686 libgc1c2
libgcc1 libsigc++-2.0-0c2a libstdc++6 libstdc++6-4.0-dev lshw man-db mysql-client-5.0
mysql-server mysql-server-5.0 nmap php5-mysql php5-mysqli telnet ubuntu-minimal
ubuntu-standard w3m
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
apt libgcc1 (due to apt) libstdc++6 (due to apt)
0 upgraded, 0 newly installed, 33 to remove and 1 not upgraded.
1 not fully installed or removed.
Need to get 0B of archives.
After unpacking 125MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
?]
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 karron » 2007-11-28 8:58

估计是混用了源.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
gwtang
帖子: 222
注册时间: 2007-05-11 8:55
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 gwtang » 2007-11-28 9:38

ls正解
fatalerr
帖子: 49
注册时间: 2007-09-06 17:54
送出感谢: 0
接收感谢: 0

#7

帖子 fatalerr » 2007-11-28 9:39

我用的应该是官方的源啊!请帮忙看看:
junl@szsrv01:~$ cat /etc/issue
Ubuntu 6.06.1 LTS \n \l

junl@szsrv01:~$ cat /etc/apt/sources.list
#
# deb cdrom:[Ubuntu-Server 6.06.1 _Dapper Drake_ - Release i386 (20060807.1)]/ dapper main restricted


deb cdrom:[Ubuntu-Server 6.06.1 _Dapper Drake_ - Release i386 (20060807.1)]/ dapper main restricted

deb http://us.archive.ubuntu.com/ubuntu/ dapper main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ dapper main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ dapper-updates main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
# deb http://us.archive.ubuntu.com/ubuntu/ dapper universe
# deb-src http://us.archive.ubuntu.com/ubuntu/ dapper universe

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://us.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse


deb http://security.ubuntu.com/ubuntu dapper-security main restricted
deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted
# deb http://security.ubuntu.com/ubuntu dapper-security universe
# deb-src http://security.ubuntu.com/ubuntu dapper-security universe
fatalerr
帖子: 49
注册时间: 2007-09-06 17:54
送出感谢: 0
接收感谢: 0

#8

帖子 fatalerr » 2007-11-28 10:02

试着用了本论坛提供的cn99的源也同样结果。
junl@szsrv01:/etc/apt$ cat sources.list
deb http://ubuntu.cn99.com/ubuntu/ dapper main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ dapper main restricted universe multiverse
apt-get update之后upgrade:
junl@szsrv01:/etc/apt$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
libc6-dev: Depends: libc6 (= 2.3.6-0ubuntu20.5) but 2.5-0ubuntu14 is installed
libc6-i686: PreDepends: libc6 (= 2.3.6-0ubuntu20.5) but 2.5-0ubuntu14 is installed
libgcc1: Depends: gcc-4.1-base (= 4.1.2-0ubuntu4) but it is not installable
E: Unmet dependencies. Try using -f.
回复

回到 “服务器基础应用”