当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]CrossFTP服务器安装出现问题,求助。。。
帖子发表于 : 2007-08-31 19:55 

注册: 2005-10-06 0:25
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
为什么我的无法安装,提示如下,我的JAVA都安装了。CrossFTP客户端都能正常运行!

系统:ubuntu 7.04
java版本为1.6

启动文件:
<?xml version="1.0" encoding="utf-8"?>

<jnlp

spec="1.0+"

codebase="http://www.crossftp.com/"

href="crossftpserver.jnlp">

<information>

<title>CrossFTP Server</title>

<vendor>Crossworld, Inc.</vendor>

<homepage href="index.htm"/>

<description>CrossFTP Server, a professional FTP Server</description>

<description kind="short">CrossFTP Server is a professional ftp server for multiple platforms.</description>

<icon href="crossftpserver_logo_32_32.gif"/>

<icon kind="splash" href="logo_pane.jpg"/>

<offline-allowed/>

<!-- Prefer a shortcut for online operation -->

<shortcut online="false">

<desktop/>

<menu submenu="CrossFTP"/>

</shortcut>

</information>

<security>

<all-permissions/>

</security>

<resources>

<j2se version="1.4+"/>

<jar href="crossftpserver.jar"/>

<jar href="commons-logging.jar"/>

<property name="apple.laf.useScreenMenuBar" value="true"/>

<property name="com.apple.mrj.application.growbox.intrudes" value="false"/>

<property name="com.apple.mrj.application.live-resize" value="true"/>

<property name="com.apple.macos.smallTabs" value="true"/>

</resources>



<application-desc main-class="org.apache.ftpserver.gui.ServerFrame"/>

</jnlp>

异常:
java.lang.NullPointerException
at javax.swing.MultiUIDefaults.getUIError(MultiUIDefaults.java:117)
at javax.swing.UIDefaults.getUI(UIDefaults.java:736)
at javax.swing.UIManager.getUI(UIManager.java:1012)
at javax.swing.JPanel.updateUI(JPanel.java:109)
at javax.swing.JPanel.<init>(JPanel.java:69)
at javax.swing.JPanel.<init>(JPanel.java:92)
at javax.swing.JPanel.<init>(JPanel.java:100)
at javax.swing.JRootPane.createGlassPane(JRootPane.java:527)
at javax.swing.JRootPane.<init>(JRootPane.java:347)
at javax.swing.JFrame.createRootPane(JFrame.java:260)
at javax.swing.JFrame.frameInit(JFrame.java:241)
at javax.swing.JFrame.<init>(JFrame.java:164)
at org.apache.ftpserver.gui.ServerFrame.<init>(ServerFrame.java:268)
at org.apache.ftpserver.gui.ServerFrame.main(ServerFrame.java:569)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at com.sun.javaws.Launcher.executeApplication(Launcher.java:1205)
at com.sun.javaws.Launcher.executeMainClass(Launcher.java:1151)
at com.sun.javaws.Launcher.doLaunchApp(Launcher.java:998)
at com.sun.javaws.Launcher.run(Launcher.java:105)
at java.lang.Thread.run(Thread.java:619)


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-09-02 12:45 

注册: 2006-06-09 20:31
帖子: 179
送出感谢: 0 次
接收感谢: 0 次
这个问题在其他的Java系统没有发现过,问题看上去是7.04的默认java版本的GTK L&F有问题。请更新到最新的Java1.6u2版本就可以运行了。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-09-09 13:10 

注册: 2007-08-04 20:26
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
想问一下如何更新到Java1.6u2版本啊?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-09-10 22:56 

注册: 2006-06-09 20:31
帖子: 179
送出感谢: 0 次
接收感谢: 0 次
有人反馈说英文locale的系统下CrossFTP Server启动不会有问题,中文的会发生问题,所以最简单的是用英文系统:)可能7.04系统附带的Java L&F对中文有问题,不清楚为什么会发生这样的情况。
Java安装是比较简单的,到Sun Java主页下载一个最新的Java linux安装包,下载运行后他会解压到当下目录。 你之后把/usr/bin下面的java和javaws指令link到新安装的目录就可以了。 启动javaws后可以进一步定制Java Web Start需要选择的Java版本。这样之后你就可以成功运行了?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-09-23 0:11 

注册: 2006-07-07 16:49
帖子: 95
送出感谢: 0 次
接收感谢: 0 次
morningboat 写道:
有人反馈说英文locale的系统下CrossFTP Server启动不会有问题,中文的会发生问题,所以最简单的是用英文系统:)可能7.04系统附带的Java L&F对中文有问题,不清楚为什么会发生这样的情况。
Java安装是比较简单的,到Sun Java主页下载一个最新的Java linux安装包,下载运行后他会解压到当下目录。 你之后把/usr/bin下面的java和javaws指令link到新安装的目录就可以了。 启动javaws后可以进一步定制Java Web Start需要选择的Java版本。这样之后你就可以成功运行了?

能说详细点么?
ln -s 说已经有了
重命名后链接又提示“ Too many levels of symbolic links”


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-09-23 0:22 

注册: 2006-07-07 16:49
帖子: 95
送出感谢: 0 次
接收感谢: 0 次
abigriver 写道:
morningboat 写道:
有人反馈说英文locale的系统下CrossFTP Server启动不会有问题,中文的会发生问题,所以最简单的是用英文系统:)可能7.04系统附带的Java L&F对中文有问题,不清楚为什么会发生这样的情况。
Java安装是比较简单的,到Sun Java主页下载一个最新的Java linux安装包,下载运行后他会解压到当下目录。 你之后把/usr/bin下面的java和javaws指令link到新安装的目录就可以了。 启动javaws后可以进一步定制Java Web Start需要选择的Java版本。这样之后你就可以成功运行了?


我解压了新的java(6u2),链接后仍然不能运行


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-09-23 22:05 

注册: 2006-06-09 20:31
帖子: 179
送出感谢: 0 次
接收感谢: 0 次
看来这是一个同中文环境相关的问题,需要等待更新版本的出现了。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-12-18 2:50 

注册: 2006-06-09 20:31
帖子: 179
送出感谢: 0 次
接收感谢: 0 次
这个问题是由于JDK6/7在Ubuntu7.x下的中文环境冲突造成的,JDK5没有这个问题。 新版本1.08应该在不久之后发布,会解决这个问题,以及其他的一些错误修正。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译