当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 遇到一个非常奇怪的掉线问题 大家帮忙看看啊。。
帖子发表于 : 2007-10-12 21:33 
头像

注册: 2007-02-07 10:15
帖子: 171
送出感谢: 0 次
接收感谢: 9
遇到一个非常奇怪的掉线问题。。。
大家帮忙看看哈。。。

我是寝室的小局域网。。。
一个四口的路由器+一个五口的交换机组成。
我的电脑在四口路由器的第一个接口。
路由器uplink接adsl。由路由器拨号。
我的电脑设置的IP为静态IP 192.168.1.17

掉线后ping 192.168.1.1结果:
pjincz@pjincz:~$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.17 icmp_seq=1 Destination Host Unreachable
From 192.168.1.17 icmp_seq=2 Destination Host Unreachable
...

掉线发生后执行arp 无法显示192.168.1.1的物理地址
pjincz@pjincz:~$ arp
地址 类型 硬件地址 标志 Mask 接口
192.168.1.1 (incomplete) eth0

然后我执行sudo arp -s 192.168.1.1 00:14:78:6E:2F:94
这里00:14:78:6E:2F:94是我们寝室路由器的物理地址
然后执行ping还是无法连接。情况和网线没有接通一样。
pjincz@pjincz:~$ sudo arp -s 192.168.1.1 00:14:78:6E:2F:94
[sudo] password for pjincz:
pjincz@pjincz:~$ arp
地址 类型 硬件地址 标志 Mask 接口
192.168.1.1 ether 00:14:78:6E:2F:94 CM eth0

稍等一会儿后执行arp再次所有物理地址失去
$sudo ifconfig eth0 down
$sudo ifconfig eth0 up
问题依旧
$sudo ifconfig eth0 192.168.1.18 #更换IP 问题依旧
pjincz@pjincz:~$ sudo /etc/init.d/networking restart
* Reconfiguring network interfaces... RTNETLINK answers: No such process
SIOCDELRT: No such process
Ignoring unknown interface eth1=eth1.
Ignoring unknown interface eth2=eth2.
Ignoring unknown interface ath0=ath0.
Ignoring unknown interface wlan0=wlan0.
[ OK ]
还是没有效果。
拔出网线重新插。。。火大。。。还是没有效果。。。
就只能重启。。
原来系统是7.04有这个问题,现在系统升级成了7.10问题依旧。
原来内核是2.6.20-15-generic,现在内核是2.6.22-14-generic
大家谁遇到过类似情况啊。。。

好像每次掉线都发生在别人复制我的samba共享的时候 这里顺便把smb.conf贴一下。。
~_~真没有天理啊。。。我的smb.conf文件实在简单的不能再简单了。。。
感觉更有可能是samba复制的时候网卡流量大的问题。
pjincz@pjincz:~$ cat /etc/samba/smb.conf
[global]
security = share
socket options = TCP_NODELAY
display charset = UTF-8
unix charset = UTF-8
dos charset = cp936

[PUBLIC]
comment = public
path = /multimedia/public
read only = yes
guest ok = yes
browseable = yes

[WRITEABLE]
comment = writeable
path = /multimedia/public/writeable
writeable = yes
guest ok = yes
browseable = yes
create directory = 0777
create mask = 0777
force user = pjincz

我用的是昂达N68PV魔固版 的集成网卡
大家说有没有是网卡不兼容的问题?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 遇到一个非常奇怪的掉线问题 大家帮忙看看啊。。
帖子发表于 : 2009-02-15 14:04 

注册: 2008-07-23 21:49
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
引用:
pjincz@pjincz:~$ sudo /etc/init.d/networking restart
* Reconfiguring network interfaces... RTNETLINK answers: No such process
SIOCDELRT: No such process
Ignoring unknown interface eth1=eth1.
Ignoring unknown interface eth2=eth2.
Ignoring unknown interface ath0=ath0.
Ignoring unknown interface wlan0=wlan0.
[ OK ]


我也是这个提示,接不上啊~!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译