当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题][解决]关于远程登陆的问题
帖子发表于 : 2007-11-07 11:07 

注册: 2007-11-07 10:41
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我有一台机器装了7.10server版本,我想问下如何配置才能另我笔记本可以远程登陆到这台server上


最后由 xijunzhe 编辑于 2007-11-13 17:28,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-07 11:17 

注册: 2007-11-07 10:41
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
是不是这么做?

代码:
UBUNTU开启TELNET服务

1. sudo apt-get install xinetd telnetd
2. 安装成功后,系统也会有相应提示,

sudo vi /etc/inetd.conf并加入以下一行
telnet stream tcp nowait telnetd /usr/sbin/tcpd /usr/sbin/in.telnetd
3. sudo vi /etc/xinetd.conf并加入以下内容:
# Simple configuration file for xinetd
#
# Some defaults, and include /etc/xinetd.d/


defaults
{


# Please note that you need a log_type line to be able to use log_on_success
# and log_on_failure. The default is the following :
# log_type = SYSLOG daemon info


instances = 60
log_type = SYSLOG authpriv
log_on_success = HOST PID
log_on_failure = HOST
cps = 25 30
}


includedir /etc/xinetd.d
4. sudo vi /etc/xinetd.d/telnet并加入以下内容:
# default: on
# description: The telnet server serves telnet sessions; it uses \
# unencrypted username/password pairs for authentication.
service telnet
{
disable = no
flags = REUSE
socket_type = stream
wait = no
user = root
server = /usr/sbin/in.telnetd
log_on_failure += USERID
}
5. 重启机器或重启网络服务sudo /etc/init.d/xinetd restart
6. 使用TELNET客户端远程登录即可进行非root用户访问。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-07 11:24 

注册: 2006-03-10 15:10
帖子: 3182
地址: xi'an China
送出感谢: 0 次
接收感谢: 2
用ssh,不用用telnet


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-07 11:27 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
启动sshd。/etc/init.d/sshd start就可以了。
建立一个临时帐号,或者自己的机器,就用现在的帐号。gftp过去就可以。
scp也可以,估计你不会喜欢。

图形的话,用vnc


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-07 20:18 

注册: 2007-09-06 17:54
帖子: 49
送出感谢: 0 次
接收感谢: 0 次
同意三楼的!装ssh,不用telnet!

我装的是6.06 server版,将安装光盘放到cdrom,然后用命令:apt-get install ssh 系统就会从光盘安装并运行sshd服务


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-11-13 2:36 

注册: 2006-11-22 22:01
帖子: 32
地址: 广西
送出感谢: 0 次
接收感谢: 0 次
我在虚拟机上照做了,telnet服务就是启动不了?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-11-13 17:23 

注册: 2007-11-07 10:41
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
问题解决了,我按照五楼的装了ssh就好了,通过ssh访问感觉还不错


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google Feedfetcher 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译