求:配置apache2支持CGI的方法!

Web、Mail、Ftp、DNS、Proxy、VPN、Samba、LDAP 等基础网络服务
回复
richie
帖子: 14
注册时间: 2007-11-15 10:35
来自: richie8848@126.com
送出感谢: 0
接收感谢: 0
联系:

求:配置apache2支持CGI的方法!

#1

帖子 richie » 2007-11-15 10:55

请问 哪位知道怎么配置apache2支持CGI啊?
我用的是ubuntu7.04,我用c编写cgi,不用perl。apache测试it works,我在/var/www下建了/cgi-bin/目录,把编写的cgi程序放进去,但显示
Not Found

The requested URL /cgi-bin/11 .cgi was not found on this server.

Apache/2.2.3 (Ubuntu) Server at 127.0.0.1 Port 80

是不是apache2.conf里面配置的问题?望高手指教!
richie
帖子: 14
注册时间: 2007-11-15 10:35
来自: richie8848@126.com
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 richie » 2007-11-16 8:53

大家都没有人知道吗?
jackielii
帖子: 184
注册时间: 2006-09-06 22:26
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 jackielii » 2008-01-23 9:14

编辑/etc/apache2/sites-available/default中的:

代码: 全选

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

代码: 全选

        ScriptAlias /cgi-bin/ /var/www/cgi-bin/
        <Directory "/var/www/cgi-bin/">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>
Little learning is a dangerous thing.
richie
帖子: 14
注册时间: 2007-11-15 10:35
来自: richie8848@126.com
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 richie » 2008-01-31 8:56

好,谢~
8)
回复

回到 “服务器基础应用”