[问题]请教在安装编译环境时遇到的问题

编译安装或者制作Deb包
回复
chenbo35
帖子: 2
注册时间: 2008-03-09 19:43
送出感谢: 0
接收感谢: 0

[问题]请教在安装编译环境时遇到的问题

#1

帖子 chenbo35 » 2008-03-09 20:06

我在建立编译环境时,在终端输入sudo apt-get install build-essential 显示不能安装
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.1.1) 但是它将不会被安装
dpkg: Breaks: dpkg-dev (< 1.14.0) 但是 1.13.24ubuntu6 正要被安装
E: 无法安装的软件包

然后我试着安装libc6-dev的时候也是出现同样的问题
下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.1.1) 但是它将不会被安装
dpkg: Breaks: dpkg-dev (< 1.14.0) 但是 1.13.24ubuntu6 正要被安装
E: 无法安装的软件包

请问这是怎么回事情啊?
先谢谢了
sandwraith
帖子: 14
注册时间: 2008-03-10 0:39
送出感谢: 0
接收感谢: 0

#2

帖子 sandwraith » 2008-04-04 9:30

我也遇到同样的问题了,希望获得解决
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#3

帖子 dbzhang800 » 2008-04-04 10:39

楼上二位能不能先核对自己设的源是不是正确的。

http://wiki.ubuntu.org.cn/Qref
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#4

帖子 yaoms » 2008-04-04 10:41

源的版本和系统版本不相符
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
回复

回到 “编译或打包”