当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]请问如何安装gcc4.2.1?
帖子发表于 : 2008-03-20 3:45 

注册: 2007-06-15 12:05
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
本人用Linux还是新手,因为毕业设计中要用到OpenMP,UBUNTU7 .10带的GCC4.1.2里没有,所以想要安装比较新的gcc。我在新立得软件包管理器里面下载安装了gcc4.2.1,执行“~$ gcc -fopenmp -D_OPENMP XX.c -o XX”编译时还是报错:cc1: 错误: 无法识别的命令行选项“-fopenmp”。用gcc --version查看还是显示gcc 版本为4.1.2。求高手帮忙指导一下怎么安装配置gcc4.2.1阿


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-02 12:56 

注册: 2008-03-26 13:03
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
我也要用openmp做毕业设计,我装的是intel c++ compiler 10.XX,linux下的非商业版可以下载,支持openmp


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-04-02 13:00 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
代码:
$ aptitude search gomp
p   lib64gomp1                      - GCC OpenMP (GOMP) support library (64bit)
p   libgomp1                        - GCC OpenMP (GOMP) support library

代码:
$ aptitude search gcc-4.2
i   gcc-4.2                         - GNU C 编译器                             
i   gcc-4.2-base                    - The GNU Compiler Collection (base package)
p   gcc-4.2-doc                     - Documentation for the GNU compilers (gcc,
p   gcc-4.2-locales                 - The GNU C compiler (native language suppor
p   gcc-4.2-multilib                - The GNU C compiler (multilib files)       
p   gcc-4.2-source                  - Source of the GNU Compiler Collection   


装 libgomp1 gcc-4.2


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译