请教:安装软件出错,怎么解决。

编译安装或者制作Deb包
回复
viger
帖子: 10
注册时间: 2008-04-08 9:58
送出感谢: 0
接收感谢: 0

请教:安装软件出错,怎么解决。

#1

帖子 viger » 2008-04-10 16:29

我是新装的ubuntu7.01 服务器版,在自己本机上(XP SP2)用WMWARE虚拟的系统。
我想编译安装一个从网上自己DOWN下来的lrzsz-0.12.20包。
以下是出错信息:
viger@v-lamp-serv:/usr/local/lrzsz$ sudo ../../lrzsz-0.12.20/configure
loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... missing
checking for gcc... gcc
checking whether the C compiler (gcc ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.

在此之前出现过检查都没通过的提示,然后我一一对应的安装了相应的软件,在装texinfo时候,没有异样,但是这里还是:checking for working makeinfo... missing
viger@v-lamp-serv:/var/deb$ info --version
info (GNU texinfo) 4.8

Copyright (C) 2004 Free Software Foundation, Inc.
There is NO warranty. You may redistribute this software
under the terms of the GNU General Public License.
For more information about these matters, see the files named COPYING.


viger@v-lamp-serv:/usr/local/lrzsz$ gcc --version
gcc (GCC) 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

可能存在的问题是我没有装上G++,不敢确定。
请论坛的朋友们帮我指出出错的地方,十分感谢!
头像
eehightech
帖子: 100
注册时间: 2007-12-18 14:25
送出感谢: 0
接收感谢: 0

#2

帖子 eehightech » 2008-04-11 16:16

sudo apt-get install cupsys-common
Reading package lists... Done
Building dependency tree... Done
The following NEW packages will be installed:
cupsys-common
0 upgraded, 1 newly installed, 0 to remove and 813 not upgraded.
20 not fully installed or removed.
Need to get 0B/1080kB of archives.
After unpacking 5345kB of additional disk space will be used.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "zh_CN:zh:en_US:en",
LC_ALL = "zh_CN.UTF-8",
LC_CTYPE = "zh_CN.UTF-8",
LANG = "zh_CN.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_ALL to default locale: No such file or directory
(Reading database ... 70107 files and directories currently installed.)
Unpacking cupsys-common (from .../cupsys-common_1.3.2-1ubuntu7.6_all.deb) ...
dpkg: error processing /var/cache/apt/archives/cupsys-common_1.3.2-1ubuntu7.6_all.deb (--unpack):
trying to overwrite `/usr/share/cups/charsets/windows-874', which is also in package cupsys
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/cupsys-common_1.3.2-1ubuntu7.6_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
回复

回到 “编译或打包”