How can I install glibc

编译安装或者制作Deb包
回复
yesilike
帖子: 203
注册时间: 2006-01-25 15:18
送出感谢: 0
接收感谢: 0

How can I install glibc

#1

帖子 yesilike » 2006-03-24 2:20

li@LHubuntu:~$ cd /home/li/download/glibc-2.3.6/glibc-2.3.6
li@LHubuntu:~/download/glibc-2.3.6/glibc-2.3.6$ ./configure
configure: error: you must configure in a separate build directory
Help me!
yesilike
帖子: 203
注册时间: 2006-01-25 15:18
送出感谢: 0
接收感谢: 0

#2

帖子 yesilike » 2006-03-24 2:21

li@LHubuntu:~/download/glibc-2.3.6/glibc-2.3.6$ sudo apt-get install glibc-2.3.6Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 无法找到软件包 glibc-2.3.6
yesilike
帖子: 203
注册时间: 2006-01-25 15:18
送出感谢: 0
接收感谢: 0

#3

帖子 yesilike » 2006-03-24 2:28

root@LHubuntu:/home/li/download# dpkg -i glibc_2.4-5_i386.deb
(正在读取数据库 ... 系统当前总共安装有 65409 个文件和目录。)
正在解压缩 glibc (从 glibc_2.4-5_i386.deb) ...
dpkg:处理 glibc_2.4-5_i386.deb (--install)时出错:
正试图覆盖“/usr/lib/gconv/ANSI_X3.110.so”,它属于软件包 libc6
dpkg-deb: 子进程 paste 被信号(断开的管道)终止了
在处理时有错误发生:
glibc_2.4-5_i386.deb
root@LHubuntu:/home/li/download#
头像
chipbug
帖子: 18
注册时间: 2006-04-07 19:11
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 chipbug » 2006-04-19 21:50

重启再试试看,
我也遇到过
dpkg-deb: 子进程 paste 被信号(断开的管道)终止了
重启就好了
fiolvivi
帖子: 2
注册时间: 2007-01-04 22:25
送出感谢: 0
接收感谢: 0

#5

帖子 fiolvivi » 2007-01-21 19:32

回到上层执行
yeahsoso
帖子: 13
注册时间: 2006-09-27 9:00
送出感谢: 0
接收感谢: 0

#6

帖子 yeahsoso » 2007-03-14 10:19

"回到上层执行"是指?
kobygao
帖子: 7
注册时间: 2007-07-14 17:15
送出感谢: 0
接收感谢: 0

#7

帖子 kobygao » 2007-07-14 17:17

怎么解决呀?我也碰到这个问题。
有一个参考的网址:http://man.chinaunix.net/linux/lfs/html ... glibc.html
不过我自己还是弄不来。
头像
wens07
帖子: 14
注册时间: 2011-07-08 16:28
送出感谢: 0
接收感谢: 0

Re: How can I install glibc

#8

帖子 wens07 » 2011-09-05 14:23

:em11
tusooa
帖子: 6546
注册时间: 2008-10-31 22:12
系统: 践兔
送出感谢: 6 次
接收感谢: 10 次
联系:

Re: How can I install glibc

#9

帖子 tusooa » 2011-09-11 20:13

代码: 全选

mkdir -pv ../glibc-build
cd ../glibc-build
../glibc-[version]/configure ...

代码: 全选

] ls -ld //
回复

回到 “编译或打包”