[问题]l安装firefox3时输入./confiure无反应

编译安装或者制作Deb包
回复
damaq
帖子: 12
注册时间: 2007-10-29 13:34
来自: 浙江台州
送出感谢: 0
接收感谢: 0

[问题]l安装firefox3时输入./confiure无反应

#1

帖子 damaq » 2008-07-24 21:26

我的U7.10系统是默认安装的,我想把里面的Firefox2.0.0.16升级到3.0版,到FF官方下载firefox-3.0.1.tar.bz2后解压:
tar jxvf firefox-3.0.1.tar.bz2
接下来应该用三步安装1: ./configure 2:make  3:make install
可是进入解压后的目录输入./configure时出现:bash: ./configure: No such file or directory
无法安装,我是新手,请教各位,谢谢。
假设安装后,是覆盖2.0版还是2.0和3.0共存?
xeoc
帖子: 1994
注册时间: 2007-05-06 10:12
送出感谢: 0
接收感谢: 0

#2

帖子 xeoc » 2008-07-24 21:52

话说ff不是编译安装来的.....详见README
damaq
帖子: 12
注册时间: 2007-10-29 13:34
来自: 浙江台州
送出感谢: 0
接收感谢: 0

#3

帖子 damaq » 2008-07-24 22:08

Readme.txt:
For information about installing, running and configuring Firefox
including a list of known issues and troubleshooting information,
refer to: http://getfirefox.com/releases/

打开http://getfirefox.com/releases/后自动转到http://www.mozillaonline.com/
在http://www.mozilla.com/en-US/firefox/3.0.1/releasenotes/上找到一段关于安装的文字:

Please note that installing Firefox 3 will overwrite your existing installation of Firefox. You won’t lose any of your bookmarks or browsing history, but some of your extensions and other add-ons might not work until updates for them are made available.

对于我这个普通桌面用户来说,还是无法安装。
头像
hubert_star
论坛版主
帖子: 5372
注册时间: 2007-10-29 22:12
系统: OSX 10.9 + Ub 1304
来自: 江苏南京
送出感谢: 0
接收感谢: 5 次

#4

帖子 hubert_star » 2008-07-24 22:15

一般情况下解压即可使用

如果需要编译安装的话首先下载source包,解压后按照如下步骤进行:

首先在构建目录创建一个.mozconfig文件,加入自己的编译参数
然后在构建目录执行:
export LDFLAGS='-lX11 -lXrender'
make -f client.mk build
make install
不过要是把你的系统原有的ff给破坏了别怪我
除了像我这样的自虐狂一般不需要自己编译的。
佛经说,人有八苦: 生、老、病、死、求不得、怨憎、爱别离、五阴盛 故我苦!
圣经说,人有七罪: 饕餮、贪婪、懒惰、淫欲、傲慢、嫉妒和暴怒  故我有罪!

我这篇帖子里面没有任何攻击我们伟大的中华人民共和国政府和任劳任怨的人民公仆(和本论坛高素质的版主)的文字和含义;

特此声明!

有些事,我们明知道是错的,也要去坚持,因为不甘心;有些人,我们明知道是爱的,也要去放弃,因为没结局;有时候,我们明知道没路了,却还在前行,因为习惯了。

欢迎来我的新浪微博@me
pan6pcpc
帖子: 21
注册时间: 2007-12-10 18:03
送出感谢: 0
接收感谢: 0

Re: [问题]l安装firefox3时输入./confiure无反应

#5

帖子 pan6pcpc » 2008-07-25 13:51

汗! 也得先看看有没有configure这个文件。
damaq
帖子: 12
注册时间: 2007-10-29 13:34
来自: 浙江台州
送出感谢: 0
接收感谢: 0

#6

帖子 damaq » 2008-08-01 21:36

用apt-get安装了3.0bet4,原来从官方下载解压的是3.0.1正式版,现在2者共存,都可使用。谢谢热心的同学们。
回复

回到 “编译或打包”