编译smplayer时出现错误提示,哪位仁兄教教我!

编译安装或者制作Deb包
回复
alien_x
帖子: 8
注册时间: 2008-08-19 3:30
送出感谢: 0
接收感谢: 0

编译smplayer时出现错误提示,哪位仁兄教教我!

#1

帖子 alien_x » 2008-09-22 2:45

In file included from prefinterface.h:22,
from preferencesdialog.cpp:25:
.ui/ui_prefinterface.h:81: 错误: ISO C++ 不允许声明无类型的‘SeekWidget’
.ui/ui_prefinterface.h:81: 错误: expected ‘;’ before ‘*’ token
.ui/ui_prefinterface.h:82: 错误: ISO C++ 不允许声明无类型的‘SeekWidget’
.ui/ui_prefinterface.h:82: 错误: expected ‘;’ before ‘*’ token
.ui/ui_prefinterface.h:83: 错误: ISO C++ 不允许声明无类型的‘SeekWidget’
.ui/ui_prefinterface.h:83: 错误: expected ‘;’ before ‘*’ token
.ui/ui_prefinterface.h:84: 错误: ISO C++ 不允许声明无类型的‘SeekWidget’
.ui/ui_prefinterface.h:84: 错误: expected ‘;’ before ‘*’ token
.ui/ui_prefinterface.h: In member function ‘void Ui_PrefInterface::setupUi(QWidget*)’:
.ui/ui_prefinterface.h:354: 错误: ‘seek1’在此作用域中尚未声明
.ui/ui_prefinterface.h:354: 错误: expected type-specifier before ‘SeekWidget’
.ui/ui_prefinterface.h:354: 错误: expected `;' before ‘SeekWidget’
.ui/ui_prefinterface.h:359: 错误: ‘seek2’在此作用域中尚未声明
.ui/ui_prefinterface.h:359: 错误: expected type-specifier before ‘SeekWidget’
.ui/ui_prefinterface.h:359: 错误: expected `;' before ‘SeekWidget’
.ui/ui_prefinterface.h:364: 错误: ‘seek3’在此作用域中尚未声明
.ui/ui_prefinterface.h:364: 错误: expected type-specifier before ‘SeekWidget’
.ui/ui_prefinterface.h:364: 错误: expected `;' before ‘SeekWidget’
.ui/ui_prefinterface.h:369: 错误: ‘seek4’在此作用域中尚未声明
.ui/ui_prefinterface.h:369: 错误: expected type-specifier before ‘SeekWidget’
.ui/ui_prefinterface.h:369: 错误: expected `;' before ‘SeekWidget’
make[1]: *** [.obj/preferencesdialog.o] 错误 1



编译smplayer时出现上面的错误提示,qt版本是4.4。
这个怎么解决阿?哪位仁兄教教我!
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

Re: 编译smplayer时出现错误提示,哪位仁兄教教我!

#2

帖子 想入非非 » 2008-09-22 12:54

没有必要编译。。。

代码: 全选

sudo apt-get install smplayer
或者现在最新版的deb安装就行了。。不过是英文菜单 :P
Ubuntu User
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

Re: 编译smplayer时出现错误提示,哪位仁兄教教我!

#3

帖子 想入非非 » 2009-03-02 14:57

不小心。。。第一次编译成功了,最近svn update之后碰到了和你一样的错误,无解中 :em06
Ubuntu User
wusun_008
帖子: 11
注册时间: 2009-02-23 15:56
送出感谢: 0
接收感谢: 0

Re: 编译smplayer时出现错误提示,哪位仁兄教教我!

#4

帖子 wusun_008 » 2009-03-03 15:11

沒有安裝 wxWidget 的dev ???
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

Re: 编译smplayer时出现错误提示,哪位仁兄教教我!

#5

帖子 想入非非 » 2009-03-03 16:42

wusun_008 写了:沒有安裝 wxWidget 的dev ???
请教一下具体的步骤,估计是升级更新的时候删除了一些依赖, :em06

代码: 全选

sudo apt-get build-dep smplayer
以前就是这样解决依赖的,最近不行了 :em06
Ubuntu User
回复

回到 “编译或打包”